Closed Bug 1500698 Opened 2 years ago Closed 28 days ago

Disable scaling on HiDPI screens when using Wayland in Thunderbird

Categories

(Thunderbird :: Untriaged, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED INCOMPLETE

People

(Reporter: jan.public, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0

Steps to reproduce:

I use Fedora with Wayland on two displays. One of the displays is a HiDPI display that is scaled to 150%.


Actual results:

Thunderbird scales up to a way too large GUI. I guess this is because Thunderbird somehow itself detects that it is on a HiDPI screen, and therefore applies the scaling. So with also the GNOME Wayland scaling on, the scaling is applied twice. This renders Thunderbird nearly useless on this configuration.


Expected results:

Thunderbird should not scale itself. Firefox had the same issue, but Firefox for Wayland has solved this issue. As a first work around I suggest to be able to disable the scaling in Thunderbird by using a configuration setting.
What is "Firefox for Wayland". Which version of FF? Can you give some details? Maybe something we need to port to TB.
(In reply to Jorg K (GMT+2) from comment #1)
> What is "Firefox for Wayland". Which version of FF? Can you give some
> details? Maybe something we need to port to TB.

Bug 635134 may help explain it.

Looks like Wayland support isn't complete yet according to that bug.

Maybe Fedora built their own Wayland version. Looks like it would be version 61?

https://www.reddit.com/r/Fedora/comments/8n84j0/newest_firefox_supports_wayland/
With "Firefox for Wayland" I mean the Fedora Firefox version that uses Wayland. The package name in fedora 28 is: firefox-wayland.x86_64 the version is: 62.0.3-4.fc28 

See this tracking bugs:
https://bugzilla.redhat.com/show_bug.cgi?id=ffwayland
https://bugzilla.mozilla.org/show_bug.cgi?id=wayland
Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → INVALID
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Blocks: wayland
No longer blocks: wayland
Blocks: tbwayland

Do you also see this issue when using versoin 68?

Whiteboard: [closeme 2020-01-04

Resolved per whiteboard

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago28 days ago
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2020-01-04
You need to log in before you can comment on or make changes to this bug.