Update Debugger Frontend v95

RESOLVED FIXED in Firefox 65

Status

enhancement
P3
normal
RESOLVED FIXED
8 months ago
8 months ago

People

(Reporter: davidwalsh, Assigned: davidwalsh)

Tracking

unspecified
Firefox 65
Dependency tree / graph

Firefox Tracking Flags

(firefox65 fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

Assignee

Updated

8 months ago
Keywords: checkin-needed
Comment on attachment 9019447 [details] [diff] [review]
1501379-1.patch

Review of attachment 9019447 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the patch David. We are missing the README update and there is one issue to fix in browser.ini. 
Regarding the localization note inconsistency, up to you to fix it or not.

::: devtools/client/debugger/new/test/mochitest/browser.ini
@@ +655,4 @@
>  [browser_dbg-asm.js]
>  [browser_dbg-async-stepping.js]
>  [browser_dbg-sourcemapped-breakpoint-console.js]
> +[browser_dbg-xhr-breakpoints.js]

The skip-if applies to the test above. Technically, the [test-name.js] creates a section, and everything until the next section applies to it (helps remembering it for me).

So here this moves the skip-if from browser_dbg-sourcemapped-breakpoint-console.js to your new browser_dbg-xhr-breakpoints.js and this is probably not what was intended.

::: devtools/client/locales/en-US/debugger.properties
@@ +518,5 @@
> +xhrBreakpoints.header=XHR Breakpoints
> +xhrBreakpoints.placeholder=Break when URL contains
> +xhrBreakpoints.label=Add XHR breakpoint
> +
> +# LOCALIZATION NOTE (pauseOnAnyXHR): The pause on any xhr checkbox description

A review comment from flod was not applied:

Case in the note should be consistent xhr -> XHR
https://github.com/devtools-html/debugger.html/pull/6934#discussion_r224149355
Attachment #9019447 - Flags: review?(jdescottes)
Assignee

Comment 3

8 months ago
Posted patch 1501379-2.patch (obsolete) — Splinter Review
Thank you Julian!  Updated all items!

https://treeherder.mozilla.org/#/jobs?repo=try&revision=b7340e821bf23c277a27d767e1ceb6e72f4ef137
Attachment #9019447 - Attachment is obsolete: true
Attachment #9019524 - Flags: review?(jdescottes)
Comment on attachment 9019524 [details] [diff] [review]
1501379-2.patch

Review of attachment 9019524 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks David, it looks good. Just the link to update in the README.

::: devtools/client/debugger/new/README.mozilla
@@ +5,2 @@
>  
>  Comparison: https://github.com/devtools-html/debugger.html/compare/release-93...release-94

We should update the link
Attachment #9019524 - Flags: review?(jdescottes) → review+
Assignee

Comment 5

8 months ago
*facepalms* Updated!
Attachment #9019524 - Attachment is obsolete: true
Attachment #9019660 - Flags: review+
Assignee

Updated

8 months ago
Keywords: checkin-needed

Comment 6

8 months ago
Pushed by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b48368889eb5
Update debugger frontend v95. r=jdescottes
Keywords: checkin-needed

Comment 7

8 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/b48368889eb5
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Assignee

Updated

8 months ago
Depends on: 1502224
Assignee

Updated

8 months ago
Depends on: 1502256
Assignee

Updated

8 months ago
Depends on: 1502494
Depends on: 1503278
No longer depends on: 1503278
You need to log in before you can comment on or make changes to this bug.