Closed Bug 1502292 Opened Last year Closed Last year

Videos/live videos are not working when going in full screen

Categories

(Firefox for Android :: Audio/Video, defect, major)

Firefox 65
ARM
Android
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 1502286
Tracking Status
firefox64 --- unaffected
firefox65 --- affected

People

(Reporter: andrei, Unassigned)

Details

Environment: 
Device: Samsung Galaxy S8+ (Android 8.0.0)
Build: Nightly 65.0a1 (2018-10-25);

Steps to reproduce:
1. Launch Fennec and go to htttp://twitch.tv.
2. Select any live channel and start watching.
3. Rotate the device on the landscape orientation or tap on the full screen button

Expected results:
The currently live video that is playing enter in full screen or rotate in landscape orientation and keeps playing.

Actual result:
The live video / screen is stuck and none of the elements from the screen can be tapped/accessed.

Notes: Every time when rotating the device back in portrait mode or tap on the back button in order to get out of full-screen, the live video will continue to play.
Also, note that when rotating the device on landscape mode is almost similar to full-screen display. But with the newest feature from Twitch now the chat is displayed right near the live video and that's why the video size is smaller.
For more details please see the attachment: https://goo.gl/sXzC4c
QA Contact: fennec
After further investigation, I was able to reproduce this issue for more websites so it is a general issue regarding all the videos and not only www.twitch.tv. 
I reproduced the issue on the following websites too: www.imdb.com, www.youtube.com(but only when rotating the device in landscape mode), www.cnn.com, www.planet.mozilla.org
Also, for few websites when changing the orientation to landscape, half of the screen is black http://prntscr.com/laph1d
Summary: Twitch.tv is not working when going in full screen or rotating the device in landscape mode → Videos/live videos are not working when going in full screen or rotating the device in landscape mode
Duplicate of this bug: 1502305
OS: Unspecified → Android
Hardware: Unspecified → ARM
Note that I have made a new video regarding this issue and I changed the summary so this reflects the full screen issue: https://goo.gl/FuiQaT 
For the landscape issue please follow this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1502305.
Summary: Videos/live videos are not working when going in full screen or rotating the device in landscape mode → Videos/live videos are not working when going in full screen
Severity: normal → major
Most likely the same issue as bug 1502286/bug 1502305.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1502286
You need to log in before you can comment on or make changes to this bug.