Closed Bug 1502286 Opened 10 months ago Closed 10 months ago

Input fields not working on Nightly

Categories

(Firefox for Android :: Keyboards and IME, defect, critical)

ARM
Android
defect
Not set
critical

Tracking

()

VERIFIED FIXED
Firefox 65
Tracking Status
firefox63 --- unaffected
firefox64 --- unaffected
firefox65 --- verified

People

(Reporter: sflorean, Assigned: jgilbert)

References

(Regression)

Details

(Keywords: regression)

Environment: 
Device:  Samsung Galaxy S8(Android 8.0.0), LG G4(Android 6.0.1);
Build: Nightly 65.0a1 (2018-10-25);

Steps to reproduce:
1. Go to any page that has input fields.
2. Type in the search field and search for something.

Expected result: Input is working and the user is able to search.

Actual result: Input is not working.

Notes:
-SignIn page is affected too.
- video: https://drive.google.com/open?id=1P9RgzPa4RW5BQ3gJ4adtXUy3YS1yp0UK
Summary: input fields not working on Nightly → Input fields not working on Nightly
Eventually the text appears, but it takes some time and in the mean time the page and URL bar are behaving strangely when scrolling.

Continuing mozregression gives me bug 1399501.
Blocks: 1399501
Flags: needinfo?(jgilbert)
Duplicate of this bug: 1502305
Duplicate of this bug: 1502292
At a guess this affects anything that resizes the screen.
Hopefully fixed by backout: https://hg.mozilla.org/mozilla-central/rev/28a4562cb517
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Assignee: nobody → nerli
Verified in the latest Nightly, tested with a variety of input fields following the steps provided in Comment 0. Everything works as expected.
Status: RESOLVED → VERIFIED
Assignee: nerli → jgilbert
Flags: needinfo?(jgilbert)

Here's the a try build from the bug that regressed this:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=8ac8b30463fa7c41baab6d901414b40b87100882&selectedJob=248812592
<oops, waiting on the actual build still>
Can I get verification that this does not regress?

Flags: needinfo?(jh+bugzilla)
Flags: needinfo?(bogdan.surd)
No longer blocks: 1399501
Regressed by: 1399501

Moving the NI on Sorina to reassign this to someone else from the QA mobile team.

Flags: needinfo?(bogdan.surd) → needinfo?(sorina.florean)

(In reply to Jeff Gilbert [:jgilbert] from comment #8)

Here's the a try build from the bug that regressed this:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=8ac8b30463fa7c41baab6d901414b40b87100882&selectedJob=248812592
<oops, waiting on the actual build still>
Can I get verification that this does not regress?

Nope, unfortunately still broken (tested by rotating from portrait to landscape).
(Edit: Using a Moto G4 Play, Android 6.0.1)

Flags: needinfo?(jh+bugzilla)

We reproduce the issue with device Samsung Galaxy S8+, Android (8.0) on the provided build from Comment 8.

Flags: needinfo?(sorina.florean)
Flags: needinfo?(sorina.florean)

Hi, the issue is still reproducible on Samsung Galaxy S8+ (Android 8.0.0) with the try build from Comment12, which has build Firefox Nightly (2019-06-04). Video attached.

Flags: needinfo?(diana.rus) → needinfo?(jgilbert)
Flags: needinfo?(sorina.florean)
Flags: needinfo?(jgilbert)

Thanks!

See Also: → 1562316
You need to log in before you can comment on or make changes to this bug.