Closed Bug 1502731 Opened Last year Closed Last year

Remove @hudButton@ and @hudButtonPressed@ and improve bookmark panel styling

Categories

(Firefox :: Theme, enhancement)

Unspecified
macOS
enhancement
Not set

Tracking

()

RESOLVED FIXED
Firefox 65
Tracking Status
firefox65 --- fixed

People

(Reporter: ntim, Assigned: ntim)

References

(Blocks 3 open bugs)

Details

Attachments

(2 files)

They're only used in the bookmarks panel and the identity panel, also their styling is outdated.

Their usage could be replaced by a .panel-button class.
Hmm, this doesn't look quite right on Linux. I don't really have time to look into why, so feel free to take over this.
This should now be ready for review.
Flags: needinfo?(dao+bmo)
Note that this shouldn't change the styling on Linux or Windows. It should only affect MacOS.

Although it would be nice to have this styling ported to Linux/Windows too.
Assignee: nobody → ntim.bugs
Flags: needinfo?(dao+bmo)
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/98406d23f4e0
Remove @hudButton@ and @hudButtonPressed@. r=dao
https://hg.mozilla.org/integration/autoland/rev/c88acd1ac1b5
Modernize MacOS bookmarking panel component styles. r=dao
Blocks: 1473922
Depends on: 1503379
Depends on: 1503381
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e80f0318d599
Fix browser_all_files_referenced.js failures. r=me
Blocks: png-cleanup
Duplicate of this bug: 1495188
Blocks: 1459877
OS: Unspecified → Mac OS X
Summary: Remove @hudButton@ and @hudButtonPressed@ → Remove @hudButton@ and @hudButtonPressed@ and improve bookmark panel styling
Duplicate of this bug: 1478392
This bug removes toolkit/themes/osx/global/icons/panel-dropmarker.png, which seems to be used by TB.
Flags: needinfo?(richard.marti)
Thank you for the info, Tim.
Flags: needinfo?(richard.marti)
Blocks: 1442296
Depends on: 1504156
You need to log in before you can comment on or make changes to this bug.