Closed Bug 1504251 Opened Last year Closed 10 months ago

Move Raptor jobs to tier 1, and turn off duplicate talos jobs

Categories

(Testing :: Raptor, defect)

Version 3
defect
Not set

Tracking

(firefox65 fixed, firefox66 fixed, firefox67 fixed)

RESOLVED FIXED
mozilla67
Tracking Status
firefox65 --- fixed
firefox66 --- fixed
firefox67 --- fixed

People

(Reporter: rwood, Assigned: jesup)

References

Details

Attachments

(3 files)

No description provided.
Assignee: nobody → rwood
Status: NEW → ASSIGNED
:jmaher, do we need to have Raptor support for stylo threads also (like the talos tp6-stylo-threads job)? Raptor doesn't have support for --stylo-threads. If we need that, I'll file a new bug for that.

I'm assuming we should leave the talos tp6-stylo-threads job running for now, and then turn it off after we add that to Raptor.
Flags: needinfo?(jmaher)
I am not sure about --stylo-threads, it appears to be added in bug 1383146, :cpeterson, do we still have a need to test talos with different stylo threads?
Flags: needinfo?(jmaher) → needinfo?(cpeterson)
(In reply to Joel Maher ( :jmaher ) (UTC-4) from comment #3)
> I am not sure about --stylo-threads, it appears to be added in bug 1383146,
> :cpeterson, do we still have a need to test talos with different stylo
> threads?

Cameron, do you still care about running Talos tp6 page load tests, AWSY, and web-platform-tests for both STYLO_THREADS=1 and STYLO_THREADS=4 (from bug 1383146)?

https://searchfox.org/mozilla-central/search?case=true&q=stylo-threads

https://searchfox.org/mozilla-central/search?case=true&q=STYLO_THREADS
Flags: needinfo?(cpeterson) → needinfo?(cam)
Pushed by rwood@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9f9a9234959f
Move Raptor jobs to tier 1, and turn off duplicate talos jobs; r=jmaher
https://hg.mozilla.org/mozilla-central/rev/9f9a9234959f
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
(In reply to Chris Peterson [:cpeterson] from comment #4)
> Cameron, do you still care about running Talos tp6 page load tests, AWSY,
> and web-platform-tests for both STYLO_THREADS=1 and STYLO_THREADS=4 (from
> bug 1383146)?

It would be good if we could keep running Talos and AWSY in both configurations, since they have some different characteristics and we don't want to regress either.

The chance of there being a correctness bug that would creep in with STYLO_THREADS=1 but not STYLO_THREADS=4 is less likely, so I wouldn't be as concerned about losing those.  (I wonder anyway if any of our platforms will naturally choose to use one styling thread?)
Flags: needinfo?(cam)

:heycam, talos tp6 stylo-threads=1 doesn't compare against anything else, we only run tp6 on raptor which is different pages, tools, and measurements. I only see value in correctness (i.e. not crashing) since talos failures will be lumped together into generic failures. Should we move this to raptor or a unittest? What difference do we get between AWSY and talos ss tp6 ?

Flags: needinfo?(cam)

:davehunt, in the previous comment (comment 9), I outline what we run and why I think we shouldn't be running tp6 on talos. Is this something we can move to raptor? I would like to simplify the sheriffs use case as much as possible and also allow for reducing the one reason for running mitmproxy in talos and the related intermittents.

Flags: needinfo?(dave.hunt)
The sheriffs are concerned about going to merge with a near-permaorange here, even if it's going to be disabled RSN.  This should turn off just tp6_google.  (A better patch might be to disable tp6 on talos entirely, but I think that's not needed in order to get green for merge - try running at https://treeherder.mozilla.org/#/jobs?repo=try&revision=8b309ddb8d3818930911483f81eeb886571673b3). Will take any r+
Attachment #9039465 - Flags: review?(jmaher)
Attachment #9039465 - Flags: review?(dave.hunt)
Assignee: rwood → rjesup
Comment on attachment 9039465 [details] [diff] [review]
disable talos tp6_google

Review of attachment 9039465 [details] [diff] [review]:
-----------------------------------------------------------------

I am fine with the talos.json changes; the timeoutmanager.cpp changes seem not so scary, but not in my wheelhouse.
Attachment #9039465 - Flags: review?(jmaher) → review+

Sorry, only the talos.json ones - I was tired and sick when I threw that up for review at 11pm

Attachment #9039465 - Flags: review?(dave.hunt)
Attached patch beta.patchSplinter Review

Beta version of the patch - and I didn't notice this bug was marked as resolved-fixed; I'll reopen since we hadn't fully disabled tp6 in talos with the initial landing. (If I'd notices, I'd have opened a second bug - sorry, it was late and I was sick).

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment on attachment 9039566 [details] [diff] [review]
beta.patch

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

Bug 1270059

User impact if declined

no user impact; near-permaorange on

Is this code covered by automated tests?

Yes

Has the fix been verified in Nightly?

Yes

Needs manual test from QE?

No

If yes, steps to reproduce

List of other uplifts needed

None

Risk to taking this patch

Low

Why is the change risky/not risky? (and alternatives if risky)

Just turning off a test

String changes made/needed

none

Attachment #9039566 - Flags: approval-mozilla-beta?
Comment on attachment 9039566 [details] [diff] [review]
beta.patch

Disable some tests. OK for beta uplift.
Attachment #9039566 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Status: REOPENED → RESOLVED
Closed: Last year10 months ago
Resolution: --- → FIXED
Target Milestone: mozilla65 → mozilla67
Flags: needinfo?(dave.hunt)

We're tracking removing talos stylo sequential threads tp6 in bug 1508694.

Flags: needinfo?(cam)
You need to log in before you can comment on or make changes to this bug.