Bug 150535 (newclassic)

Improve Classic buttons and icons

RESOLVED WONTFIX

Status

SeaMonkey
Themes
RESOLVED WONTFIX
16 years ago
7 years ago

People

(Reporter: Greg Valure, Assigned: Greg Valure)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(5 attachments, 3 obsolete attachments)

(Assignee)

Description

16 years ago
Asa notes in bug 125526: "I've been told on many occasions by the creators and
maintainers (as well as some in UE) that classic isn't supposed to be an exact
copy of 4.x and that we've made improvements where we could."

I'm proposing improving the appearance of the Classic theme buttons and icons
while keeping the same general style, i.e. not make the changes so dramatic that
they would be better off as a separate theme.

The attachment illustrates the type of improvements I have in mind.  Three
versions of the Back button with more and more significant changes applied, yet
all clearly similar to the original.  I personally like the last one the best,
but I can understand not dropping the shadow.  All colors are from the web-safe
palette, and it could easily be made more cyan if that's desired.

I only did the Back button because I'd like to get comments and know exactly
what's acceptable before spending too much effort.  Please CC anybody who should
have a say in this.
(Assignee)

Comment 1

16 years ago
Created attachment 87071 [details]
Example

Example using the Back button.

Comment 2

16 years ago
I think this is a good start. I'm ccing some folks  who would want to have a 
say.  For me the new shading is good - but the tint of the green is too 
intense..

Comment 3

16 years ago
Greg, I think this looks great but I agree with Andreww. I think it's a little
intense. I'd love to see what this looks like in an actual full skin. If you
could create a skin "Classic2" with these icon changes and it is well received
then perhaps we can move to it. 

Comment 4

16 years ago
i am just wondering if it matters that classic would no longer be 8 bit platform
'safe'.  since that was classic's main requirement.
(Assignee)

Comment 5

16 years ago
Actually it is 8-bit safe, since it uses the web palette.  The greens are
#003300, #006600, etc.

How attached are we to the stop light?  I was thinking about it, and that's the
only significant style change I'd like to add.  IE, Opera, and Modern all use
some form of X, so maybe Classic should too.

Did anyone mind losing the shadow in #4?
(Assignee)

Comment 6

16 years ago
Created attachment 87153 [details]
Better example

Okay, here's a more complete example with the icons in context.  Forward, Back,
Reload, and the bookmark icons are improved.  I didn't touch Stop yet.	Shows a
before and after in 98 and XP styles.
(Assignee)

Comment 7

16 years ago
...the arrow colors were softened a bit too.

Comment 8

16 years ago
The Mozilla Browser project has some reworked icons for it's version of the
Classic skin.

http://lxr.mozilla.org/mozilla/source/browser/base/resources/skin/buttons.gif

I Like this version of the Reload button better than the current classic button,
and the longer tails on the Arrows are a big improvement. The Stop light is
still there though and I'd prefer some kind of X.
(Assignee)

Comment 9

16 years ago
Created attachment 88078 [details]
Theme using new icons

Okay, here's a theme using the new icons.  I only did the browser; I'll do
Composer and Mail in separate bugs if this is approved.

All the icons use the web-safe palette and are similar in style to the
originals.  The only exception is the Stop button, which was turned into an X. 
I can make a stoplight if this is a problem.

Comments?
(Assignee)

Comment 10

16 years ago
Created attachment 88264 [details]
Less noticable improvements

Some of the subtler improvements present in the theme.

Comment 11

16 years ago
I like it.  Colors are much better, icons look crisper and tied together better.
 Especially on XP since the color scheme is already lighter by default.  I like
the stop button as the X rather than the stoplight too.  This looks/feels less
"klunky" than the old classic, and I think it brings it back to life.  I hope,
if this doesn't actually end up being the new classic, that you might still
release this as a complete theme.  Have you done, or considered, any work on
sharpening/brightening the component bar icons?  They kind of blend right in to
the background on XP.  Thanks.
(Assignee)

Comment 12

16 years ago
If this is approved I'll probably touch all the icons in one way or another. 
The big question mark at this point is the X.  It takes a little getting used
to, especially if you're very used to Classic, and breaks from the idea of
Classic approximating Netscape 4.  However, if you give it a day or two, it
really does fit in and it follows the conventions of all other browsers.

The question is what do we put first?  Familiarity for Netscape 4 users or
general browser convention?  Ususally they don't conflict, but I think they do
here.  Personally, I think we should change it.  Netscape 4 users would
immediately "get it" even if it wasn't quite as familiar.

Now, if you have a problem with my version of the X button, that's another issue
altogether...

Comment 13

16 years ago
I like the overall look  but I wonder if it's too dark  with all the shadowing  
going on  like in the folder icons, etc.

There's also alot more than composer and mail, there's addressbook, 
and on the commercial side, aim as well that would need to be updated.

It would be great to get a installable version of this when you are done so 
that we could test it out using all the various windows, color depths, etc.
(Assignee)

Comment 14

16 years ago
Created attachment 88858 [details]
Theme 1.1 (browser only)

I brightened the folder shading so that the average color is now the same as it
was before.  I also brightened Stop, Home, and the inner part of the Reload
arrow slightly.

I would greatly prefer to do this component by component rather than all at
once for a number of reasons:
 1) I would know if this type of thing will even be approved before tackling
the other components.
 2) I would get feedback ahead of time.  For example, if I had a complete theme
right now, I might have needed to brighten a good number of icons instead of
just a few.  Issues that come up for one component will be in mind when working
on the next.
 3) The changes aren't to the general style of the theme, and components are
relatively independent when it comes to icons, so upgrading one component at a
time won't cause it to feel like two separate themes.  For example, Mail only
shares the Print and Stop icons with the browser, and they don't feel like part
of a different theme when next to the others.

If this really must be done all at once, I want hewitt or someone else who
would provide a sr= to informally approve each component as its finished, so I
know it WOULD be checked in, if not just yet.  That would take away 1 and 2,
which are important because I'm not a Netscape employee nor do I have unlimited
free time.
Attachment #88078 - Attachment is obsolete: true

Comment 15

16 years ago
I agree with your points. This is in a way a test case for seeing if it's 
possible to move beyond the set in stone skins and begin to allow them 
to evolve as they should.   I dont know of a process for moving this forward 
- other than getting a concensus of folks  who are in module - owner type 
positions and keep evangelizing it.

The reason I talked about getting an installable version going is that it 
makes it possible to present this before others and get buy-in for it...

I'm not sure if this is not an all-or-nothing deal,  since updating only parts 
of the skin at a time will leave it having a patchwork appearance and not 
be consistent across the applications.

Perhaps another way to do this is to start with widgets, move to the 
smaller icons, then finally tackle the larger icons on the toolbars.

Modern and classic are "special" skins in that they are the "default" for 
either NS7 or mozilla. so there is the added onus of making sure that 
when they are updated they dont regress on some given platform.

I think what you seem to be looking for initially is something like "should I  
even continue to spend time on this?" and I believe that in my opinion this 
is a worthwhile effort.  

Adding Asa for comments.

Comment 16

16 years ago
Also see bug 139029 [Classic theme] Icons of the mail toolbar are messy.

That bug has updated mail toolbar icons attached to it.
(Assignee)

Comment 17

16 years ago
That's more along the lines of what I did in bug 123666 (although mine was much
more picky and trivial :) -- it's correcting problems in the icons instead of
really changing them.  There's no reason it shouldn't go in, so I'll guide it
through.  This bug could eventually obsolete it, but it's still good in the
meantime, and this bug still isn't guaranteed to go through yet.
Status: NEW → ASSIGNED

Comment 18

16 years ago
Created attachment 92143 [details]
boxes around reload button

i'm running 1.1, my only complaint is about roundness of the reload button.
we have to overlook that reload is three dimensional (see mpt references that
indicate buttons should be flat).

when i look at the reload button, it looks like the bottom edge pulls away too
quickly. i think this can be fixed by making the bottom lines in the dark
green, dark red and red boxes match the corresponding top lines (width, not
necessarily color)

Comment 19

16 years ago
Sorry for spam but couldnt resist on great design. NewClassic seems really cool
but need to work on navigator/editor/adress book icons they are too old too. And
home icon of course :) .
But still great work and would be nice to see in Mozilla 1.1 final

Just my 0.02$

Comment 20

16 years ago
[08:41:30] <coldacid> should set an alias on it, perhaps "newclassic"
[08:41:38] <timeless> yeah please do

I just caught that after hitting Commit when adding myself to CC. Sorry for the
bugspam!
Alias: newclassic

Comment 21

16 years ago
Side-by-side comparison:
http://www.xsta.cc/mozilla/new_vs_old_classic.png

I'm looking forward to seeing this in the trunk.

The icon to the left of about:blank should be reverted to the old icon or to one
that looks less washed out.  Also, the brightness change in bookmark folders
gives the impression that newclassic folders are taller - you may want to try
decreasing the height in order to counter that effect. The folders appear a bit
bright for my taste but that's personal preference as much as anything else.
(Assignee)

Comment 22

16 years ago
Thanks for the support.  I plan on resuming work on this shortly.

Comment 23

16 years ago
note that the xbl form controls in the current newclassic are broken (it's
probably simple enough to replace the files, but...), so anyone planning to try
to improve xbl form controls should suffer with classic instead. :-(
(Assignee)

Comment 24

16 years ago
Created attachment 94852 [details]
Theme 1.2 (browser/composer only)

Another version, this time improving Composer as well.	While it isn't the most
used part of Mozilla, it was definitely the worst looking.  It should now be on
par with the browser.

The rest of the files are swiped from build 2002-07-21 (1.1b), so it might
clear up any problems caused by the other files being older.  I have no idea
what build the 1.1 theme took its files from.

timeless:  I evened out the bottom of reload a bit, although some of the
problems you're seeing are caused by you having the background color set to the
same as the highlight color.

hampton:  I wasn't thrilled with the default page icon either.	The new one
should be better.  As for the folders, the tabs are one pixel taller to make
them stand out better.	I originally had them darker, but changed it so the
average brightness is the same as the originals.  See comment 13.
Attachment #88858 - Attachment is obsolete: true
(Assignee)

Comment 25

16 years ago
Created attachment 94853 [details]
Composer improvements

Comment 26

16 years ago
There is a problem with Theme 1.2

If the spellchecker from mozdev is installed the Spelling button displays the
link icon instead of the spelling icon. This error shows up in messengercompose
as well as in composer because it gets it's icon from btn1.gif in composer. 

This will affect Netscape builds using this theme because of the default
spellchecker included in Netscape and future Mozilla builds if the spellchecker
is ever added to Mozilla builds.
(Assignee)

Comment 27

16 years ago
I forgot that I didn't do the icons that weren't on the default toolbar yet. 
It's fixed now, so just download it again with the same link.  I also improved
the icon on Composer's Source tab.

Comment 28

16 years ago
Is there any progress on this bug ? As mozilla theme version is incremented old
links wont work for 1.2b

Comment 29

16 years ago
Greg, let's start working to get this stuff in. Even if we have to go icon by 
icon and make this current bug a meta bug, i'm sure we can get things 
going again.

I have a stick in my craw to get mac osx classic skin out of the world of 
suckage it's in right now.
(Assignee)

Comment 30

16 years ago
Yeah, I haven't really been able to work on this this past month.  Ironically, I
just started on it again this morning.  Time's still a little tight, but I'll
try to get this moving again.

Meta sounds good to me.  I'll put out a bug for Navigator.  I want to touch up
Composer a little more (especially the spell check icon) and then I'll put out a
bug on that too.  I just started on Messenger so that might take a little while.
(Assignee)

Comment 31

16 years ago
Okay, bug 170000 is for the browser.  It already has a patch attached.  All
three files are part of the patch.
Depends on: 170000

Comment 32

16 years ago
i've merged the current file from greg's site with the classic changes since his
version, you can get it by clicking the 'url' link at the top of the bug.

Comment 33

16 years ago
merged with 1.3 from this weekend: resizer and junk are now supported.
(Assignee)

Comment 34

15 years ago
Hello all.  With the release of the new roadmap, it doesn't look like this bug
is necessary anymore.  After 1.4 the project's moving towards Phoenix, which
doesn't use the clunky old Classic theme.  I doubt they'll carry it over, and
they really shouldn't.

But fear not!  Once I figure out a better name I'll submit New Classic to the
various theme sites, so if you've grown attached it will still be available. 
I'll also make a Phoenix version and submit that too.  I'll announce here so
keep your CC's if you're interested.

I'm thinking about renaming it because "New Classic" is kind of contradictory. 
E-mail me your suggestions and I'll announce the new name here as well.  DON'T
POST THEM HERE.  I'm sure the 21 CC's don't want all the spam.

Sorry I didn't have time to finish this, but fortunately the problem looks like
it's going to be solved.  Mozilla will start looking respectable by default.

Comment 35

15 years ago
Greg, I don't they'll be dropping Classic. Maybe they'll spruce up the icons and
call it something else.

The power of the classic theme is that it's not just built on CSS, but on the
ability desktop appearance preferences. That's something a lot of people have
fought for.

I don't know how it works underneath. I think it's called nsITheme or something.
(Assignee)

Comment 36

15 years ago
The current default theme is Qute, and briefly looking through its CSS files I
see that it's using colors like ThreeDLightShadow instead of hard-coded ones, so
it looks like it should have a native platform appearance.  Do you believe that
they'll be replacing Qute's buttons with the old Classic ones?
(Assignee)

Comment 37

15 years ago
New Classic is now Classique on DeskMod.  It will be sent to themes.mozdev.org
too once they get their submissions page working.  Worth switching because I
reapplied my changes, so it includes some minor CSS tweaks that have been added
to Classic since the last release.

http://mozilla.deskmod.com/?show=showskin&skin_id=30718

I'm not sure about Phoenix for now since I've found out it has more icons than
Mozilla, and thus the theme wouldn't be complete there either.
(Assignee)

Updated

15 years ago
Attachment #94852 - Attachment is obsolete: true
(Assignee)

Comment 38

15 years ago
Closing.  Will reopen if the current Classic icons somehow make their way into
Phoenix.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX

Comment 39

14 years ago
Maybe it's a bit late for me to say this now, but it's likely that we won't see
Firefox officially "replace" the suite for at least a little while now (as
opposed to the immediate 1.5 change expected a year ago this time) ... so maybe
you might want to at least consider this. :)

Comment 40

14 years ago
*** Bug 244443 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 41

14 years ago
There seems to be a little renewed interest in this so I'll give an update.

It's been a year since I last touched this and I'm not going to have time to
start working on it again.  I'm going to be busy for about another month, and
even then I have my own open source project I've been neglecting because of it (
http://naturaldocs.org ).

My thoughts on replacing Classic are as follows:

- Unless there's a big vested interest in keeping the theme looking somewhat
like the old Communicator one, adapt Qute.  The consistency between Mozilla
Foundation applications would be a good thing.

- Otherwise, unless there's a big vested interest in using the web-safe palette,
which I think has become a dated requirement long ago, start from scratch. 
Smooth color fades will look better than all the hatching.

- Otherwise, if someone wants to finish this off, I can whip up a zip file of
the changed icons and diffs of all the changed files.  I'll reopen and reassign
the bug.  I think it's just mail, the address book, and the component bar that
need to be done.

Comment 42

14 years ago
CCing Daniel Wang who seem to have similar graphics (see Bug 218329, comment 8).
Hopefully, he or anyone else can continue this important project. Without an up
to date look, Mozilla makes a very poor first impression.

Prog.

Comment 43

14 years ago
A port of Qute to the Mozilla suite is already in progress; I started it last
winter, and it is being continued by another volunteer (see the MozillaZine
"Themes" form for a thread on this).

As for a classic-stlye theme: if it is to officially replace Classic, the
Web-safe colors will probably be a must so that it can match up with the
original Classic's "requirements"; otherwise, if it's just a this-decade-looking
version of Classic, I don't see any reason to be confined by them.

And as for me, I can make a theme if given the icons, but my graphics-making
abilities aren't that good. Still, I could try--I do remember trying to make a
similar theme a few years ago (though I did give up). :)

Comment 44

10 years ago
Suggesting FIXED as there is now a new icon set for Classic.
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.