Closed Bug 1506109 Opened Last year Closed Last year

crash in webrender_bindings::moz2d_renderer::rasterize_blob

Categories

(Core :: Graphics: WebRender, defect, P2, critical)

Unspecified
All
defect

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- unaffected
firefox64 --- unaffected
firefox65 --- fixed

People

(Reporter: mayankleoboy1, Assigned: mattwoodrow)

References

(Blocks 2 open bugs, )

Details

(Keywords: crash, nightly-community, regression)

Crash Data

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

Steps to reproduce:

enable WR
go to https://www.twosigma.com/careers/

let the animation do its thing for some time.. maybe try to interact with the page


Actual results:

crash
https://crash-stats.mozilla.com/report/index/2419c022-3e72-43a1-bf17-7b3040181109
Severity: normal → critical
Crash Signature: [@ webrender_bindings::moz2d_renderer::rasterize_blob ]
Whiteboard: crash
Debian Testing, KDE, GTX1060
bp-4a568133-9ff0-428c-b012-a6c460181109
> MOZ_CRASH Reason (Sanitized) 	Moz2D replay problem

https://hg.mozilla.org/mozilla-central/log/c6c46594d92a

RUST_BACKTRACE=1 mozregression --repo autoland --launch c6c46594d92a -B debug --pref gfx.webrender.all:true -a https://www.twosigma.com/careers/ -a https://www.twosigma.com/careers/
> 3:44.53 INFO: Assertion failure: aSize.width > 0 && aSize.height > 0, at /builds/worker/workspace/build/src/gfx/webrender_bindings/Moz2DImageRenderer.cpp:328
> 3:44.53 INFO: #01: ???[/tmp/tmpnRxLeQ/firefox/libxul.so +0x5505a6f]
> 3:44.53 INFO: #02: ???[/tmp/tmpnRxLeQ/firefox/libxul.so +0x54eeef7]
> 3:44.53 INFO: #03: _$LT$webrender_bindings..moz2d_renderer..Moz2dBlobRasterizer$u20$as$u20$webrender_api..image..AsyncBlobImageRasterizer$GT$::rasterize::he7bfcf3f065c46dc[/tmp/tmpnRxLeQ/firefox/libxul.so +0x5505986]


RUST_BACKTRACE=1 mozregression --repo autoland --launch 774f5ab895af -B debug --pref gfx.webrender.all:true -a https://www.twosigma.com/careers/ -a https://www.twosigma.com/careers/
Can't repro, yes, seems to be "last good".
Flags: needinfo?(matt.woodrow)
OS: Unspecified → All
Priority: -- → P3
Whiteboard: crash
maybe try zooming in on the page, and/or selecting text inside the box with svg
On the other hand, there were 4 crashes with build 20181102100039, days before bug 1456555.
Assignee: nobody → matt.woodrow
Flags: needinfo?(matt.woodrow)
Bumping this to P2 since it's fairly easy to reproduce. Volume is low, but that might just be Nightly.
Priority: P3 → P2
Fixed by bug 1506576
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
You need to log in before you can comment on or make changes to this bug.