Closed Bug 1506397 Opened Last year Closed Last year

Pocket icon is displayed multiple times after clicking on the address bar icon

Categories

(Firefox :: Pocket, defect, P1)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
Firefox 65
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- unaffected
firefox64 --- unaffected
firefox65 + verified

People

(Reporter: github, Assigned: dao)

References

Details

(Keywords: nightly-community, regression)

Attachments

(2 files)

Attached image screenshot-issue
With fresh profile and the current desktop build (2018-11-10, build from https://hg.mozilla.org/mozilla-central/rev/e9ff3fec51d3de454f607b69b4acddc2a81409c1) I see a graphic issue when I'm clicking on the pocket icon. Screenshot is attached. Webrender doesn't matter (tested with both), if logged in or not doens't affect it either. I'm here using macOS 10.14.1.
[Tracking Requested - why for this release]:

Dão, this is a regression from library-animatable-box bug 1506114. Like Patrick, I'm also use macOS 10.14.1.

I bisected this bug to this pushlog:

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=22d335fc020fb0509c67c4a945db21a27b8332d4&tochange=781581f8c129546f4cc626fefcaac2d77781cec1
Blocks: 1506114
Flags: needinfo?(dao+bmo)
Keywords: regression
Summary: Pocket icon is displayed multiple times after clicking on the icon → Pocket icon is displayed multiple times after clicking on the address bar icon
Status: UNCONFIRMED → NEW
Ever confirmed: true
I ran into this on Linux, too (Ubuntu 18.10).  So, this definitely isn't platform-specific.
OS: Unspecified → All
bug 1506114's patch removed two lines from "pocket.css":
 #pocket-button-box[animate="true"] > #pocket-animatable-box,
 #pocket-button > .toolbarbutton-animatable-box {
-  position: absolute;
-  overflow: hidden;
https://hg.mozilla.org/integration/autoland/rev/781581f8c129#l3.10

If I add those 2 lines back in the Browser Toolbox, then this starts working correctly again, FWIW. (Something else might break, but I haven't noticed it.)

Dão, was there a reason we needed to remove those lines, or was that part of the "clean up" mentioned in the commit message?  (If they were just nonessential "clean up", then maybe we can just restore them?)
Actually, I'll bet you intended/expected that "#pocket-animatable-box" element to have class="toolbarbutton-animatable-box" (which would indeed make these styles redundant).

But it does *not* have that class right now.  We have that class on some toolbar elements, but not on this pocket box.  So it looks like either:
 (1) we need to restore those styles
...or:
 (2) we need to give that box the toolbarbutton-animatable-box class
...or:
 (3) we need to edit the new location of these styles ("toolbarbutton-icons.inc.css"*) and give it a #pocket-button-box[animate="true"] > #pocket-animatable-box selector alongside the .toolbarbutton-animatable-box selector.

* https://hg.mozilla.org/integration/autoland/rev/781581f8c129#l4.2
(In reply to Daniel Holbert [:dholbert] from comment #4)
> Actually, I'll bet you intended/expected that "#pocket-animatable-box"
> element to have class="toolbarbutton-animatable-box" (which would indeed
> make these styles redundant).

*sigh* Yep.
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Flags: needinfo?(dao+bmo)
Priority: -- → P1
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5ce13fbe4561
Fix saved to pocket animation in the url bar. r=jaws
Duplicate of this bug: 1506489
Duplicate of this bug: 1506944
Duplicate of this bug: 1506963
https://hg.mozilla.org/mozilla-central/rev/5ce13fbe4561
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Duplicate of this bug: 1507130
I can reproduce this issue with nightly 65.0a1 (2018-11-10) (64-bit) in Linux x86_64

I can verify that this is no longer reproducible in latest beta 65.0b6

Build ID 	20181220174318
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [testday-20181221]
You need to log in before you can comment on or make changes to this bug.