Closed Bug 1507484 Opened 1 year ago Closed 1 year ago

Implement minimal Ion support for BigInt

Categories

(Core :: JavaScript Engine, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox65 --- disabled
firefox66 --- disabled
firefox67 --- fixed

People

(Reporter: wingo, Assigned: terpri)

References

Details

Attachments

(1 file, 1 obsolete file)

Bug 1505849 lands some beginnings of JIT support for BigInt, but there are still failures:

$ ../js/src/tests/jstests.py dist/bin/js non262/reflect-parse/expression.js
## non262/reflect-parse/expression.js: rc = -11, run time = 0.102644
Hit MOZ_CRASH(Unexpected type) at /home/wingo/src/mozilla-inbound/js/src/jit/CacheIRCompiler.cpp:1686
REGRESSION - non262/reflect-parse/expression.js
[0|1|0|0] 100% ==========================================================>|   0.5s
REGRESSIONS
    non262/reflect-parse/expression.js
FAIL

Instead of fixing these problems in that bug, let's fix in a follow-up.

Rough draft of Ion support for BigInt values

Attached file arcpatch-D14826-range-diff.txt (obsolete) —

git range-diff for phabricator updates from diff #8 to diff #12

Attachment #9039746 - Attachment description: Bug 1507484 - Implement JIT support for BigInt → Bug 1507484 - Implement minimal Ion support for BigInt
Summary: Implement JIT support for BigInt → Implement minimal Ion support for BigInt
Attachment #9041223 - Attachment is obsolete: true
Keywords: checkin-needed

We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again. (255, 'applying /tmp/tmpOEXy_8\npatching file js/src/jit/arm64/CodeGenerator-arm64.cpp\nHunk #1 FAILED at 811\n1 out of 3 hunks FAILED -- saving rejects to file js/src/jit/arm64/CodeGenerator-arm64.cpp.rej\npatching file js/src/jit/MacroAssembler.cpp\nHunk #1 FAILED at 100\n1 out of 2 hunks FAILED -- saving rejects to file js/src/jit/MacroAssembler.cpp.rej\npatching file js/src/jit/CodeGenerator.cpp\nHunk #11 FAILED at 11731\n1 out of 12 hunks FAILED -- saving rejects to file js/src/jit/CodeGenerator.cpp.rej\nabort: patch failed to apply', '')

Flags: needinfo?(wingo)
Keywords: checkin-needed

i rebased the last diff to include formatting changes from bug 1519636; it should be ready to land now

try run: https://treeherder.mozilla.org/#/jobs?repo=try&revision=43b7752940772ef8f4c5217c45a06c9f9bddfe22

Assignee: wingo → robin
Flags: needinfo?(wingo)
Keywords: checkin-needed

Pushed by nerli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cf113c9d6075
Implement minimal Ion support for BigInt r=wingo,jandem

Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

Changed ff66 status to disabled because it's behind ENABLE_BIGINT which is off in ff66.

Duplicate of this bug: 1523360
You need to log in before you can comment on or make changes to this bug.