Closed Bug 1508156 Opened 2 years ago Closed 11 months ago

Use fluent for the default application choice section of about:preferences

Categories

(Firefox :: Preferences, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 71
Tracking Status
firefox65 --- wontfix
firefox71 --- fixed

People

(Reporter: jack, Assigned: chenbri2, Mentored)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 2 obsolete files)

The default application choice strings under about:preferences > General > Applications should be updated to use Fluent for localization.
Assignee: nobody → jack
Blocks: 1486917
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P3
See Also: → 1533477
Assignee: jack → chenbri2

Took inherited patch and removed .tooltiptext attributes from strings in fluent file because they appeared to be unused. Revised migration script accordingly and tested it. Looking into alternatives to organize fluent strings for javascript files.

Attachment #9028079 - Attachment is obsolete: true
Attachment #9056760 - Attachment is obsolete: true
Pushed by zbraniecki@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c78b3c900c3e
Use fluent for the default application choice section of about:preferences. r=fluent-reviewers,Gijs,flod
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
Regressions: 1584080
Regressions: 1586355
Regressions: 1593806
Regressions: 1624122
No longer regressions: 1624122
Regressions: 1624122
You need to log in before you can comment on or make changes to this bug.