Closed Bug 1509125 Opened 2 years ago Closed 2 years ago

[remote-dbg-next] Add public API on debugger-client to check if a client is already connected

Categories

(DevTools :: about:debugging, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1515612

People

(Reporter: jdescottes, Unassigned)

References

Details

We currently can't call connect() on an already connected DebuggerClient instance.

For remote debugging we are keeping and reusing connected clients between different tools. It would be nice if we could directly have an API on DebuggerClient to know if the client is connected or not. Additionally (or alternatively) we could make connect() safe to call on already connected clients.
Priority: -- → P3
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1515612
No longer blocks: remote-debugging-ng-m2
You need to log in before you can comment on or make changes to this bug.