Closed Bug 1515612 Opened 8 months ago Closed 7 months ago

[remote-dbg-next] Runtime page is not updated when closing Network Location runtime

Categories

(DevTools :: about:debugging, defect, P1)

defect

Tracking

(firefox66 fixed)

RESOLVED FIXED
Firefox 66
Tracking Status
firefox66 --- fixed

People

(Reporter: jdescottes, Assigned: jdescottes)

References

(Blocks 1 open bug)

Details

Attachments

(6 files)

STRs:
- start one Firefox in regular mode
- start another Firefox in remote debug mode (eg `./mach run --start-debugger-server -P someOtherProfile`). Debug port should be in the terminal "Started debugger server on 6080"
- open about:debugging-new on first Firefox
- enable network locations in about:config (devtools.aboutdebugging.network)
- go to connect page, add a network location for the second firefox "localhost:6080"
- connect to it and select it to open its runtime page
- quit the debugger server Firefox

ER: The runtime page should close, or indicate that the server is no longer available
AR: Nothing happens, the page is still displayed, you can click on buttons but nothing happens.
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Priority: -- → P1
Blocks: 1503911
Attachment #9033427 - Attachment description: Bug 1515612 - Update Network runtimes after receiving closed event on Debugger client;r=daisuke,ladybenko,ola → Bug 1515612 - Update Network runtimes after receiving closed event on Debugger client;r=ladybenko,ola
Attachment #9033429 - Attachment description: Bug 1515612 - Disconnect all the invalid clients when updating remote clients;r=daisuke,ladybenko,ola → Bug 1515612 - Disconnect all the invalid clients when updating remote clients;r=ladybenko,ola
Attachment #9033430 - Attachment description: Bug 1515612 - Test navigation to this-firefox when a remote client closes;r=ladybenko,daisuke,ola → Bug 1515612 - Test navigation to this-firefox when a remote client closes;r=ladybenko,ola
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/eee3227176bb
Split PAGE_SELECTED action in START/SUCCESS/FAILURE subactions;r=ladybenko,Ola
https://hg.mozilla.org/integration/autoland/rev/97b28c1b8a85
Update Network runtimes after receiving closed event on Debugger client;r=ladybenko,Ola
https://hg.mozilla.org/integration/autoland/rev/552427e973d5
Disconnect all the invalid clients when updating remote clients;r=ladybenko
https://hg.mozilla.org/integration/autoland/rev/5345e8472f29
Test navigation to this-firefox when a remote client closes;r=ladybenko,Ola

There are also dt6 failures oon browser_aboutdebugging_addons_remote_runtime.js
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=220872793&repo=autoland&lineNumber=1494

Flags: needinfo?(jdescottes)
See Also: → 1517676
Duplicate of this bug: 1517676
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/66a7369d4c51
Remove unneeded addListener;r=ladybenko
https://hg.mozilla.org/integration/autoland/rev/958fb1212e11
Split PAGE_SELECTED action in START/SUCCESS/FAILURE subactions;r=ladybenko,Ola
https://hg.mozilla.org/integration/autoland/rev/9fc243c2626c
Update Network runtimes after receiving closed event on Debugger client;r=ladybenko,Ola
https://hg.mozilla.org/integration/autoland/rev/d19483d0f411
Disconnect all the invalid clients when updating remote clients;r=ladybenko
https://hg.mozilla.org/integration/autoland/rev/5caf4fb0d4f6
Test navigation to this-firefox when a remote client closes;r=ladybenko,Ola
Duplicate of this bug: 1503911
Duplicate of this bug: 1509125

Verified as fixed on Firefox Nightly 68.0a1, Firefox Dev Edition 67.0b4 and on Firefox 66.0.1 on Windows 10 x 64, Mac OS X 10.14 and on Ubuntu 16.04 x64 as "This Nightly" tab is selected after closing Network Location runtime.

But what is the expected behavior of the devtools toolbox of the debugger server after closing Network Location runtime?
When the focus is on "Console/Debugger" panel, devtools toolbox turns blank (keeping the same URL as before).
When the focus is on "Inspector" panel, devtools toolbox doesn't turn blank totally. (See screenshot attached)

Flags: needinfo?(jdescottes)

This is currently being worked on in Bug 1505368. For now the target is to remain on the same URL but show an error message.

Flags: needinfo?(jdescottes)
You need to log in before you can comment on or make changes to this bug.