Closed Bug 1510266 Opened 10 months ago Closed 10 months ago

reply/forward etc buttons in mail header no longer shown using View | Headers | All

Categories

(Thunderbird :: Theme, defect)

Unspecified
Windows 10
defect
Not set

Tracking

(thunderbird60 unaffected, thunderbird61 unaffected, thunderbird62 unaffected, thunderbird63 unaffected, thunderbird64 wontfix, thunderbird65 fixed)

RESOLVED FIXED
Thunderbird 65.0
Tracking Status
thunderbird60 --- unaffected
thunderbird61 --- unaffected
thunderbird62 --- unaffected
thunderbird63 --- unaffected
thunderbird64 --- wontfix
thunderbird65 --- fixed

People

(Reporter: alice0775, Assigned: mkmelin)

References

Details

(Keywords: regression)

Attachments

(5 files, 1 obsolete file)

Attached image screenshot 63 vs 64
Steps To reproduce:
1. Receive a HTML mail contains images
2. Select the mail in the list view
3. View > Headeres > All

Actual Results:
No longer available repry delete button etc in mail-headerfield
See attached screenshot

Expected Results:
All Buttons should be visible.
And Provide horizontal scroll bar so that another header items will be visible.


Regression window:
https://hg.mozilla.org/comm-central/pushloghtml?fromchange=997d19872dcfda69cf137ebc563d9bd2cc8a6ab5&tochange=86e1a9121b5d5bf67043e611b356462214a67dba
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b42bb6bb0be8723d0dd2b3c857c554cefa763062&tochange=095ec59a8800360154df6668394803e5a84d031c

Suspect: 	08bf719c34e9	Magnus Melin — Bug 1489748 - Migrate mail-headerfield and mail-urlfield to a single custom element. r=arshad
Keywords: regression
Flags: needinfo?(mkmelin+mozilla)
I don't see this on linux trunk at least.

Do you see this for all mails?
Flags: needinfo?(mkmelin+mozilla)
Summary: No longer visible GUI buttons in mail-headerfield → reply/forward etc buttons in mail header no longer shown using View | Headers | All
Attached image 1510266.png
Taken with trunk compiled a few hours ago. Looks fine to me, sorry about the French (testing lang packs). Also looking good in TB 64 beta 3.
(In reply to Jorg K (GMT+1) from comment #2)
> Created attachment 9028058 [details]
> 1510266.png
> 
> Taken with trunk compiled a few hours ago. Looks fine to me, sorry about the
> French (testing lang packs). Also looking good in TB 64 beta 3.


I can still reproduce the latest comm-cemtral Windows 2012 x64 opt.
https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=fab70cf9e35485946adfc8a507210a6f837c64e0
could you test withe this email?
Hmm, on TB 64 beta 3 I see the From line followed by a lot of empty space followed by the rest of the headers. There is a scrollbar, so I can scroll to the end. Magnus, what do you see?
In fullscreen on my 3440px monitor everything is ok ;-). On a normal window width I see it too. The problem is that the headerValue elements for DKIM etc. are way too wide and don't break to new lines at the end of the window.

I saw also that the rules mail-headerfield > .headerValue:focus no more apply because of the changed structure.
Flags: needinfo?(arshdkhn1)
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #9028236 - Flags: review?(richard.marti)
Flags: needinfo?(arshdkhn1)
Comment on attachment 9028236 [details] [diff] [review]
bug1510266_headerbuttons_out_of_view.patch

The focus is fixed now. But this patch creates big spaces between the headers when they overflow. I'll attach a screenshot.
Attachment #9028236 - Flags: review?(richard.marti) → review-
Attached image big_spaces.png
The spaces between the header fields when they overflow.
I've seen that in the stand-alone window, but I don't think it's due to this patch.
Without patch the fields do wrap very wide and fill the gaps. With the patch they overflow but the narrower the window is the more space is between the fields. It looks like they wrap but no text is shown because of the overflow.
Something odd going on here. If I add arbitrary max-height to some elements here the stray spacings clean up themselves.

Anyway, found a better fix that doesn't leave spaces either.
Attachment #9028236 - Attachment is obsolete: true
Attachment #9028585 - Flags: review?(richard.marti)
Comment on attachment 9028585 [details] [diff] [review]
bug1510266_headerbuttons_out_of_view.patch

Thanks.
Attachment #9028585 - Flags: review?(richard.marti) → review+
Keywords: checkin-needed
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/dd4e2acab2ab
ensure header buttons are not pushed out of view when we have a long header. r=Paenglab
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 65.0
Blocks: 1512596
Till patch land in 65.0 version, the obvious workaround to fix issue, for earlier affected version, is to set view setting to Normal (default value):

View > Headers > Normal
You need to log in before you can comment on or make changes to this bug.