Closed Bug 1510899 Opened Last year Closed Last year

Enable catch-up compositing with WebRender

Categories

(Core :: Graphics: WebRender, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox65 --- fixed

People

(Reporter: mattwoodrow, Assigned: mattwoodrow)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Currently WebRender discards vsync notifications if there is an existing composite in progress, meaning that a slow composite forces the next one to also be delayed.

This is different to the non-WR behaviour, where slow composites block the vsync message from being processed, and we handle it late when we return to the message loop.

It's possible that this behaviour is preferable, but we want to minimize unrelated differences to make comparisons easier.
Priority: -- → P2
MozReview-Commit-ID: LXIpsvZZ96U
Pushed by mwoodrow@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/55abd0f51161
Try catch up composites with WR. r=jrmuizel,sotaro
https://hg.mozilla.org/mozilla-central/rev/55abd0f51161
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
This bug caused a performance regression on thalos see bug 1511797
(In reply to Bobby Holley (:bholley) from comment #6)
> This regressed tp5o_scroll on Windows [1]. Matt?
> 
> [1]
> https://treeherder.mozilla.org/perf.html#/graphs?series=mozilla-central,
> 1663184,1,1&series=autoland,1684084,1,1&series=mozilla-central,1538379,1,
> 1&zoom=1543495379899.2747,1543565056579.3716,2.163670371980703,2.
> 9632958401454967&selected=autoland,1684084,409386,660044972,1

Looks like we have bug 1511797 tracking this now, I'm investigating.
Flags: needinfo?(matt.woodrow)
See Also: → 1513254
You need to log in before you can comment on or make changes to this bug.