Personal Toolbar not working after importing NS4 profile

RESOLVED DUPLICATE of bug 146391

Status

SeaMonkey
Bookmarks & History
--
major
RESOLVED DUPLICATE of bug 146391
16 years ago
14 years ago

People

(Reporter: Gert-Jan Vons, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

I just installed Mozilla 1.0 on an XP system which has an installation of
Netscape 4.79. During the installation, Mozilla imported my netscape user profile.

However, after starting mozilla, I can't add bookmarks to the Personal Toolbar,
dropping bookmarks on it does nothing at all.

Reproducible: Didn't try
Steps to Reproduce:
1. install fresh copy of NS4.7x
2. don't use it, i.e. don't create bookmarks within NS
3. install Mozilla and have it import the NS4.x user profile

Actual Results:  dragging and dropping bookmarks to mozilla's personal toolbar
doesn't work, dropping bookmarks on the toolbar does nothing at all.

Expected Results:  I'd expect the bookmarks to be added to the toolbar.

After manually creating a "Personal Toolbar Folder" in Mozilla, the toolbar
started working.

Something that probably explains what is happening is that even though NN4.79
was installed, I didn't use it yet (installed the PC recently, and used IE
instead until now).

This means that the NS4 profile didn't have any bookmarks at all, and its
bookmark.htm does not have the Personal Toolbar folder by default; apparently it
is only created when you add the first bookmark to NN's personal toolbar.

So I assume that since the imported NN profile did't have a personal toolbar
folder yet, Mozilla didn't create one either.

When dropping a bookmark on NN's personal toolbar, NN creates the folder
automatically when it doesn't exist yet, whereas Mozilla just ignores the
dropped bookmarks.

I think that either

- the Mozilla installation should make sure there always is a Personal Toolbar
folder, even when importing an existing netscape profile.

or 

- when bookmarks are dropped on the personal toolbar, Mozilla should check the
existance of the personal toolbar folder and create it if it doesn't exist yet

The 2nd solution is more user-friendly and is what NN4.7x seems to do.

Comment 1

16 years ago
This may be a duplicate of bug 146390.

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 146391 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.