Closed Bug 1512180 Opened 9 months ago Closed 9 months ago

Open All in Tabs not working

Categories

(Firefox :: Bookmarks & History, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 65
Tracking Status
firefox-esr60 --- unaffected
firefox64 --- unaffected
firefox65 --- verified

People

(Reporter: bc, Assigned: tobyfrederickward)

References

Details

(Keywords: regression, Whiteboard: [fxsearch])

Beginning with either this morning's (20181205102000) or last evening's updates, opening Bookmark folders using Open All in Tabs no longer works on Linux x86_64.

I couldn't find where this was already filed. I'll try to find the regressor using mozregression.
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=ffc42da8138efd66299329615945c433bcafc2da&tochange=81a6b32f2a8bf8e8579ecc6ae81ae7f0d12f0d91

better steps to reproduce

1. enable bookmarks toolbar visibility
2. create a folder in the toolbar
3. add a couple of urls to it.
4. open the folder in the toolbar and clck Open All in Tabs *inside* the folder.

expected results

all urls open in tabs

actual results

nothing happens

Note if you right click the folder and click the Open in All tabs in the context menu it still works.
Blocks: 1435562
Flags: needinfo?(tobyfrederickward)
Component: Tabbed Browser → Bookmarks & History
Priority: -- → P1
Whiteboard: [fxsearch]
Also occurring on Win10
Summary: Open All in Tabs not working Linux / 20181205102000 → Open All in Tabs not working
In addition to clicking not working for "Open All in Tabs" it also doesn't respond to pressing enter on the keyboard when selected.
Hi Bob,

Apologies for this, I've just had a look at this myself and reproduced the bug. I recommend backing out my changeset for now as this is definitely responsible for the issue and was a fix for a lower priority bug, although I don't have the power to do this as this is only my second bug.

I'm not 100% sure why this is occurring myself; Open All in Tabs definitely works in the Library panel, so the way the Bookmarks toolbar handles it must be different.

I'm going to needinfo @Standard8 just to be sure on how to proceed as I've not had this happen before myself.
Flags: needinfo?(tobyfrederickward) → needinfo?(standard8)
Duplicate of this bug: 1512398
Hi All,

I'm pretty confident I've identified the issue but just have to test it to make sure it is what I think it is. There was a leftover function call [1] that was unified with a different function in my changeset that wasn't submitted for some reason. I believe changing this to openMultipleLinksInTabs should fix the issue.

Toby

[1] https://searchfox.org/mozilla-central/source/browser/components/places/content/browserPlacesViews.js#661
Toby: No problem! Things happen. I applaud your efforts. We're both part of the community working together!
(In reply to Toby Ward from comment #6)
> Hi All,
> 
> I'm pretty confident I've identified the issue but just have to test it to
> make sure it is what I think it is. There was a leftover function call [1]
> that was unified with a different function in my changeset that wasn't
> submitted for some reason. I believe changing this to
> openMultipleLinksInTabs should fix the issue.

Hi Toby, the patch has been backed out at this point (I pinged sheriffs earlier), also considering this would end up in Beta. 

I'm going to mark this as fixed, since the problem itself should be gone in the next Nightly build.
Status: NEW → RESOLVED
Closed: 9 months ago
Flags: needinfo?(standard8)
Resolution: --- → FIXED
Duplicate of this bug: 1512680
Assignee: nobody → tobyfrederickward
Target Milestone: --- → Firefox 65
Duplicate of this bug: 1513431
Duplicate of this bug: 1513431
Flags: qe-verify+
I have managed to reproduce the issue using Fx 65.0a1 buildID: 20181205213623.

The issue is verified fixed using Fx65.0b7 and Fx66.0a1 on macOS 10.14, Ubuntu 16.04 and Windows 10 x64. The 'Open All in Tabs' option from inside the bookmark folder now correctly opens all the bookmarks in new tabs.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.