Implement GUI preference control for Quartz Text Smoothing

RESOLVED WONTFIX

Status

()

Core
XUL
--
enhancement
RESOLVED WONTFIX
16 years ago
16 years ago

People

(Reporter: Giovanni Derks, Assigned: Marc Attinasi)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
As you can read on
http://www.eternaltedium.com/cgi-bin/chimeraboard/ikonboard.cgi?s=3d07d7ad038dffff;act=ST;f=7;t=8
and
http://www.eternaltedium.com/cgi-bin/chimeraboard/ikonboard.cgi?s=3d07d7ad038dffff;act=ST;f=1;t=32
(that are 2 pages of a chimera forum; chimera is a mozilla based browser fo os
x) many people (me included!) don't like to have text smoothing when they see a
page content cause in certain cases it is hard for read.

Now.. There must be a feature, in the preferences, that lets you disable it.
Better if you can choose from:

- disable it at all
- disable it for fonts < than XX pixels.

Thanks,
Giovanni

Comment 1

16 years ago
That's more appropriately implemented at the OS level, not the application level.

Comment 2

16 years ago
(Forgot to include:) As such, you should suggest that to Apple.

Comment 3

16 years ago
Actually, the smoothing disable for small sizes is already implemented at the OS
level, in the General preference pane.

Comment 4

16 years ago
Revising Summary to cover the other requested feature. It was mentioned in bug
149427, but I'm not sure if it was implemented there.
Component: Layout → XP Toolkit/Widgets
Summary: Antialiased text in Mozilla 1.1 for Mac OS X 10.1.5 → Implement preference control for Quartz Text Rendering

Updated

16 years ago
Depends on: 149427
(Reporter)

Comment 5

16 years ago
I know that you can set it in the Mac OS X preferences panel.. But it should be
implemented also from the browser cause many users can prefer to have 2
different settings between the browser and all the remaining applications that
they own. A web page with antialiased text shows different than in linux or
windows and that isn't good for me. If a application is antialiased this doesn't
matter.

I hope I well explained my idea :-P

bye
I don't understand why the same textsize would be unreadable in a browser but 
not in another application?
(Reporter)

Comment 7

16 years ago
Not Unreadable, simply different.. Bug .. if a website is designed on windows or
linux without using the antialiasing it will looking different on a Mac OS X
computer and in same case "different" could be also defined "bad" ! .. And ..
and this is very important .. if you use courier size 12 it is different than
verdena size 2, expecially with anti-aliasing. Now i'm using chimera that uses
courier with the same dimension I use in Mail.app but it isn't the same thing at
all.. It is harder to me to see what I write and my eyes aren't happy !! :)

So please .. it is just a matter of make a enhancement .. I don't ask to disable
it..

Mozilla is great, and we can make it great for everybody ;) Customisation is a
powerful word!

bye,
Giovanni
(Reporter)

Comment 8

16 years ago
On the first line of my last comment I had wrote "bug" instead of "but" :-P

anyway.. if you have other question see the 2 links i reported above

(

http://www.eternaltedium.com/cgi-bin/chimeraboard/ikonboard.cgi?s=3d07d7ad038dffff;act=ST;f=7;t=8

http://www.eternaltedium.com/cgi-bin/chimeraboard/ikonboard.cgi?s=3d07d7ad038dffff;act=ST;f=1;t=32

)

bye.

Updated

16 years ago
Summary: Implement preference control for Quartz Text Rendering → Implement preference control for Quartz Text Smoothing

Comment 9

16 years ago
I'm in agreement with Giovanni that the ability to turn off the anti aliasing
would be a nice feature.  The system already does some anti aliasing to fonts,
but this new Quartz rendering seems to be overkill at times...

Comment 10

16 years ago
Please, no evangelism comments. If you want this, vote for it.

Comment 11

16 years ago
In message [news://news.mozilla.org:119/3D0997C6.9050704@mac.com], Riscky
suggests this preference may be already implemented:

"if you add user_pref("browser.quartz.enable", false); to user.js that *should*
turn it off... I have however been unable to get that to work."

I have not tried to verify this. Pinkerton suggests in a reply to the message
that this may work in tomorrow's builds.

Comment 12

16 years ago
*** Bug 150161 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
user_pref("browser.quartz.enable", false); now works as of Build 2002061503. 
There is, however, no setting in the Preferences dialog box which can be set, as
far as I can tell.

Comment 14

16 years ago
Since this issue was addressed by the patch in bug 149427, resolving as a
duplicate of that bug.

*** This bug has been marked as a duplicate of 149427 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 15

16 years ago
I don't think it's a duplicate : bug 149427 implements the anti-aliasing itself.
There's no way to control it in the GUI, which is what this bug is all about.

Comment 16

16 years ago
*** Bug 159513 has been marked as a duplicate of this bug. ***

Comment 17

16 years ago
*** Bug 164783 has been marked as a duplicate of this bug. ***

Comment 18

16 years ago
Reopening bug - this is *not* a duplicate of bug 149427. What is needed here, is
a preference in the GUI to disable font-aliasing, just like Mac IE has.

This is very useful for web-designers, becuase their webpages will look
different on other platforms. And it can also be used to speed up Mozilla. At
the very least, it can be used to demonstrate what anti-aliasing is, and why
Apple's solution is better.

There are also quite a number of problems with the current implementation of
anti-aliasing (we need full ATSUI support), so this preference could be used as
a workaround.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 19

16 years ago
Okay, I'll confirm as an RFE to get it off UNCO. Up to the Mozilla guys whether
or not they want to do this.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Implement preference control for Quartz Text Smoothing → Implement GUI preference control for Quartz Text Smoothing

Comment 20

16 years ago
Don't hold your breath for this, by any means. Personally, I recommend WONTFIX.
I'm a web developer myself, and I don't need this at all. Turning off text
smoothing isn't an adequate test of what my pages will look like on another
platform.

As for demonstarting antialiasing, there are already system-level tools to
disable it. Doing so on an application level is pure fluff.

Comment 21

16 years ago
I agree this should be a WONTFIX, see MPT's rants against excessive options
(passim). Between the system-level option and prefs.js we've got more than
enough configurability without the extra implementation/testing/debug/QA work of
a new UI option just for one platform.

Comment 22

16 years ago
Why don’t you guys mark this with DONTWANTTOWORK ?
(Reporter)

Comment 23

16 years ago
Hey Greg,
you said "I'm a web developer myself, and I don't need this at all. Turning off
text smoothing isn't an adequate test of what my pages will look like on another
platform."

..Well, if you are a good web developer, now you should take care to have your
site looking good both with and without antialiased text.
And .. as a good web developer you should know that many many many users (i
think 80%) of expecially windows, linux and mac os 9 has not antialiased text in
their browser. Another thing .. I have mandrake 8.2 and mac os x .. now .. in
mandrake 8.2 with mozilla antialiased text it is a must but unfortunately I
can't use it for now cause I have mozilla 0.9.8 .. In Mac OS X i consider font
smoothing as a double smoothing .. try to see a 16px font in Linux and a 16px
font in mac os x, without text smoothing .. on linux with antialiased font it
will looks more like in mac os x without antialiased font.

If you don't believe me, or don't well understand my poor english, I can take
some screenshots and put them on the web to make it clear once for all ;-)

and IE (for os x) has this "fluff", for the 80% of internet users.. this why you
should reconsider it as something of needed, not a "fluff" !!

-- 4 chibi: "DONTWANTTOWORK" .. eheh ;) nope .. they are good guys n I trust in
them.. I think they want to work more than me!

Comment 24

16 years ago
If the application has the option via manual editing of the prefs-file to do
this, why not support in the GUI? To a lot of MacOS X users I think this is an
important issue.

I can just quote one of our art directors a long time windows-user. When she
started up Mac IE with antialiasing she just said "The text looks funny and
strange. I don't like this. Can't you do something about it?" Well it was a
simple matter of unticking the checkbox.

We use a lot of Mozilla in our bureau but since I don't want to run around
editing all the staffs prefs-files we probably won't be upgrading to 1.1. And as
for OS level feature disabling I _do_ want the font smoothing for Aqua (the UI),
but I _don't_ want it for webpages. So that is not a satisfactory solution for me.
As Greg has already pointed out multiple times, it is the OS's responsibility to
en- or disable anti-aliasing. For the convenience of an overall (arguably) nicer
look, OS X chooses to anti-alias almost any text, unless it's rendered using old
toolkits or in a very small font size.

An application should *not* be able to override system-wide settings like this
one, unless the implementation of the technology is incomplete, which I do not
happen to agree with (IOW, Mozilla and Chimera appear to be able to use Quartz
anti-aliasing just fine).

The non-GUI pref is probably there because anti-aliasing in Mozilla and Chimera
*used* to be buggy.

The argument that webpages become unreadable is non-sense: If you cannot read a
webpage in a certain font size with a certain font family, that will be the case
with the very same font combination in *any* *other* application, so you should
complain at Apple for not providing an option to turn the *whole* anti-aliasing
off in Mac OS X. And if the "web designer" is unable to design their pages in a
platform-independent way, they should read the W3C specs again (if they have
read it in the first place at all).

Unless the developers disagree (hopefully with good reasons), this is a WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WONTFIX

Comment 26

16 years ago
Bottomline:
Aqua is designed for fontsmoothing, 99.9 % of webpages are not.

I want font smoothing in Aqua, but not on webpages. Is that so hard a concept to
grasp?

I believe that I'm not alone in this wish. Say what you want about Microsoft but
there´s probably a lot of marketresearch that made them put the option to
disable fontsmoothing in their GUI. If this isn't resolved I for one will
probably opt for some other browser. Maybe I'm unique, maybe I'm not.

Aqua is visually pleasing since the design is adapted to the fontsmoothing
throughout the entire GUI. Most webpages are designed for the non smoothed text
we've adapted to and look rightout ugly with smoothing.

I suggest a simple checkbox under Appearance->Fonts titled "Enable Quartz
fontsmoothing". Make it ticked by default. Not hard to implement and a nice
service to users.

I hope someone with the right priviledges will reopen this RFE.
You need to log in before you can comment on or make changes to this bug.