Closed Bug 151404 Opened 22 years ago Closed 22 years ago

print preview shows plain HTML source of <noframes> section

Categories

(Core :: Print Preview, defect)

x86
Windows NT
defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 133809

People

(Reporter: christophe.thalet, Assigned: rods)

Details

printing the following file should simply produce white text on green
background saying "Hello, I am frame 1" but it produces a page 2 which
contains plain HTML sourcecode of the <noframes> section.
Two files follow as an example

---------------SNIP begin of file demo.html-------
<html>

<frameset rows="100%,*" border=0 frameborder=0 framespacing=0>
<frame src="frame1.html" name="frame1" marginwidth=0 marginheight=0 noresize>
</frameset>

<noframes>

<!-- NOW YOU SEE PLAIN HTML SOURCE -->

<body bgcolor=#aa0000 text=#ffffff>

<b>Hello, this HTML source should not appear
when printing this page.<br>
<br>
But it does with Mozilla Build ID 2002053012<br>
</b>

</body>
</noframes>
</html>
---------------SNIP end of file demo.html---------

---------------SNIP begin of file frame1.html-----
<html>
<body bgcolor=#00aa00 text=#ffffff>
<b>Hello, I am frame 1</b>
</body>
</html>
---------------SNIP end of file frame1.html-------
this is a dup
Whiteboard: DUPME
of which bug?
If I could remember, I would dup it, in fact I worked on it a little. Ultimately
it is a core layout issue, but I think it is still asigned to me.
Thinking of bug 108502, maybe?
I cannot reproduce this with Mozilla 1.1 beta on win98
reporter, what system & browser version are you using?

*** This bug has been marked as a duplicate of 133809 ***
Status: UNCONFIRMED → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPME
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.