Closed Bug 1514616 Opened 4 years ago Closed 4 years ago

Intermittent /webdriver/tests/set_window_rect/set.py | test_fully_exit_fullscreen - AssertionError: timeout (500):

Categories

(Testing :: geckodriver, defect, P5)

Version 3
defect

Tracking

(firefox65 fixed, firefox66 fixed)

RESOLVED FIXED
mozilla66
Tracking Status
firefox65 --- fixed
firefox66 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: whimboo)

References

Details

(Keywords: intermittent-failure)

Filed by: dvarga [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=217318105&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/aAujDfpBQNOfQNc-0Bk6lA/runs/0/artifacts/public/logs/live_backing.log

11:50:50     INFO - TEST-PASS | /webdriver/tests/set_window_rect/set.py | test_no_change[rect16] 
11:50:50     INFO - TEST-PASS | /webdriver/tests/set_window_rect/set.py | test_no_change[rect17] 
11:50:50     INFO - TEST-PASS | /webdriver/tests/set_window_rect/set.py | test_no_change[rect18] 
11:50:50     INFO - TEST-PASS | /webdriver/tests/set_window_rect/set.py | test_no_change[rect19] 
11:50:50     INFO - TEST-UNEXPECTED-FAIL | /webdriver/tests/set_window_rect/set.py | test_fully_exit_fullscreen - AssertionError: timeout (500):
11:50:50     INFO - session = <Session f95cb93a-8956-414b-9d5c-004b0dd508c5>
11:50:50     INFO - 
11:50:50     INFO -     def test_fully_exit_fullscreen(session):
11:50:50     INFO -         session.window.fullscreen()
11:50:50     INFO -         assert is_fullscreen(session)
11:50:50     INFO -     
11:50:50     INFO -         response = set_window_rect(session, {"width": 400, "height": 400})
11:50:50     INFO - >       value = assert_success(response)
11:50:50     INFO - 
11:50:50     INFO - response   = <Response status=500 error=<TimeoutException http_status=500>>
11:50:50     INFO - session    = <Session f95cb93a-8956-414b-9d5c-004b0dd508c5>
11:50:50     INFO - 
11:50:50     INFO - tests/web-platform/tests/webdriver/tests/set_window_rect/set.py:139: 
11:50:50     INFO - _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 
11:50:50     INFO - 
11:50:50     INFO - response = <Response status=500 error=<TimeoutException http_status=500>>
11:50:50     INFO - value = None
11:50:50     INFO - 
11:50:50     INFO -     def assert_success(response, value=None):
11:50:50     INFO -         """
11:50:50     INFO -         Verify that the provided webdriver.Response instance described
11:50:50     INFO -         a valid error response as defined by `dfn-send-an-error` and
11:50:50     INFO -         the provided error code.
11:50:50     INFO -     
11:50:50     INFO -         :param response: ``webdriver.Response`` instance.
11:50:50     INFO -         :param value: Expected value of the response body, if any.
11:50:50     INFO -         """
11:50:50     INFO - >       assert response.status == 200, str(response.error)
11:50:50     INFO - E       AssertionError: timeout (500):
This is caused by a hang in SetWindowRect, and as such dependent on bug 1489955:

11:50:36     INFO - PID 1237 | 1544989836282	Marionette	DEBUG	0 -> [0,884,"WebDriver:SetWindowRect",{"height":400,"width":400}]
11:50:37     INFO - PID 1237 | 1544989837784	Marionette	DEBUG	0 <- [1,884,{"error":"timeout","message":"","stacktrace":"WebDriverError@chrome://marionette/content/error.js:179:5\nTimeoutError@chrome://marionette/content/error.js:446:5\nbail@chrome://marionette/content/sync.js:212:19\n"},null]
11:50:37     INFO - PID 1237 | 1544989837784	webdriver::server	DEBUG	<- 500 Internal Server Error {"value":
Depends on: 1489955
Depends on: 1515867
See Also: → 1515775
Depends on: 1517414
Blocks: 1515867
No longer depends on: 1515867
See Also: → 1506245
Depends on: 1478358

Actually this is first occurring for going into fullscreen:

15:13:39 INFO - PID 1236 | 1547334819385 Marionette DEBUG 0 -> [0,882,"WebDriver:FullscreenWindow",{}]
15:13:40 INFO - PID 1236 | 1547334820886 Marionette WARN TimedPromise timed out after 1500 ms: stacktrace:
15:13:40 INFO - PID 1236 | bail@chrome://marionette/content/sync.js:196:64
15:13:40 INFO - PID 1236 | 1547334820902 Marionette DEBUG 0 <- [1,882,null,{"x":0,"y":0,"width":1280,"height":1024,"state":"fullscreen"}]
15:13:40 INFO - PID 1236 | 1547334820902 webdriver::server DEBUG <- 200 OK {"value":{"x":0,"y":0,"width":1280,"height":1024}}
15:13:40 INFO - PID 1236 | 1547334820904 webdriver::server DEBUG -> POST /session/9cf382cd-32db-af4d-9689-3757ba5671f7/execute/sync {"args": [], "script": "\n return !!(window.fullScreen || document.webkitIsFullScreen)\n "}
15:13:40 INFO - PID 1236 | 1547334820906 Marionette DEBUG 0 -> [0,883,"WebDriver:ExecuteScript",{"args":[],"script":"\n return !!(window.fullScreen || document.webkitIsFullScreen)\n "}]
15:13:40 INFO - PID 1236 | 1547334820911 Marionette DEBUG 0 <- [1,883,null,{"value":true}]
15:13:40 INFO - PID 1236 | 1547334820911 webdriver::server DEBUG <- 200 OK {"value":true}
15:13:40 INFO - PID 1236 | 1547334820913 webdriver::server DEBUG -> POST /session/9cf382cd-32db-af4d-9689-3757ba5671f7/window/rect {"width": 400, "height": 400}
15:13:40 INFO - PID 1236 | 1547334820915 Marionette DEBUG 0 -> [0,884,"WebDriver:SetWindowRect",{"height":400,"width":400}]
15:13:42 INFO - PID 1236 | 1547334822418 Marionette DEBUG 0 <- [1,884,{"error":"timeout","message":"","stacktrace":"WebDriverError@chrome://marionette/content/error.js:179:5\nTimeoutError@chrome://marionette/content/error.js:446:5\nbail@chrome://marionette/content/sync.js:193:19\n"},null]
15:13:42 INFO - PID 1236 | 1547334822418 webdriver::server DEBUG <- 500 Internal Server Error {"value":{"error":"timeout","message":"","stacktrace":"WebDriverError@chrome://marionette/content/error.js:179:5\nTimeoutError@chrome://marionette/content/error.js:446:5\nbail@chrome://marionette/content/sync.js:193:19\n"}}

The timeout in SetWindowRect is a follow-up failure, but shouldn't also happen.

Depends on: 1519777

With bug 1521527 fixed no timeout errors are raised anymore for fullscreen.

Assignee: nobody → hskupin
Status: NEW → RESOLVED
Closed: 4 years ago
Depends on: 1521527
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
You need to log in before you can comment on or make changes to this bug.