Closed Bug 1514780 Opened 2 years ago Closed 1 year ago

Use the new tokenizer in UnifiedComplete (to make restriction characters handling more consistent)

Categories

(Firefox :: Address Bar, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 66
Tracking Status
firefox66 --- fixed

People

(Reporter: mak, Assigned: mak)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fxsearch])

Attachments

(1 file)

For some reason restriction tokens are breaking the search, no results are returned when searching for "* moz" for example.
This is actually due to the different tokenizer we use in the new and old code, the new tokenizer considers "*moz" as a research on bookmarks for the word "moz", while UnifiedComplete considers it a search for "*moz".
The best path forward would probably be to use the new tokenizer in unifiedcomplete, that is not exactly trivial, but it would allow us to hammer down some of its potential bugs.
Priority: P1 → P2
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Summary: Fix search with restriction characters → Use the new tokenizer in UnifiedComplete (to make restriction characters handling more consistent)
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/f2f4a6eb1576
Use the Quantum Bar tokenizer in UnifiedComplete. r=adw
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Depends on: 1537640
Depends on: 1538050
Depends on: 1539701
Regressions: 1541399
No longer depends on: 1538050
Regressions: 1538050
Regressions: 1544380
No longer depends on: 1537640
Regressions: 1537640
Regressions: 1606143
You need to log in before you can comment on or make changes to this bug.