Closed Bug 1606143 Opened 1 year ago Closed 1 year ago

Octothorpe/sharp/hash/pound marks are elided from end of searches of history

Categories

(Firefox :: Address Bar, defect)

Desktop
Linux
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox-esr68 --- wontfix
firefox71 --- wontfix
firefox72 --- wontfix
firefox73 --- wontfix

People

(Reporter: fdiciocco, Unassigned)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Steps to reproduce:

Open a new tab
In the address bar type a random string (e.g. flor) and press enter. The search is made.
Then, in a new tab or the same one, type in the address bar the same random string but ending with "#" (e.g. flor#).

Actual results:
The first historic search is shown as a suggestion, despite typing the # on the second search.

Expected results:
The historic search should not be shown once I've typed the # since it no longer matches with what I had typed in (flor is different from flor#)

Priority: P1 → --
Summary: Octothorpe/sharp/hash/pound and question marks are elided from end of searches of history → Octothorpe/sharp/hash/pound marks are elided from end of searches of history
Attached video search.mp4

Does this have the same regression range as bug 1560228?

Hi Ryan,

I don't know because I couldn't find the regression range of said bug. But here's the regression range of mine:

It was working properly until version 66 included. From FF67 onwards the issue is present.
Last good revision: 1312db5d495953cc6e18b16d082d06d611a21166 (2019-01-16)
First bad revision: 1db2248f441513991df17a73112ffd9cc1846846 (2019-01-17)

And here's the pushlog: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=d11bb3bd81951e0e5a66bc9e3ae80ca22d2ad13f&tochange=f2f4a6eb1576cba580ee99971f5fc035cbaeeab1

Regards, Flor.

Has Regression Range: --- → yes
Has STR: --- → yes
Flags: needinfo?(fdiciocco)
Regressed by: 1514780

I think the current behavior is the correct one.
# is a special restriction character (search only titles), as such it is removed from the string before looking for results.
But it is not removed from the string sent to the search engine when pressing enter, as a result of bug 1560228 (so one can search for c# remotely).
Supporting both behaviors is not possible without something like bug 1590732 and a new UI.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.