Closed Bug 15148 Opened 20 years ago Closed 19 years ago

[RFE] UI buttons for temporary disabling.

Categories

(SeaMonkey :: General, enhancement, P3)

enhancement

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 20826
Future

People

(Reporter: CodeMachine, Assigned: vishy)

References

Details

(Keywords: helpwanted)

There are a whole lot of things users might sometimes want on, and sometimes
off.  See bug #7380 for a list of these things.

It would be really nice if you could have buttons in the UI toolbar for each of
these.  Heaps of people would find them useful.  To prevent UI overcrowding, see
bug #15144.

The things in bug #7380 all would have a preference.  This button would not
affect the preference.  If you had a preference that applied to all sites, the
state of these buttons would stay the same throughout the session.

If you had the preference change when moving between pages (see bug #7380),
there are two options.  Either change the toolbar state, or make these buttons
have three states, on, off and "normal" setting.  The problem with the latter is
that you would need a tristate toolbutton, and also it would not show the
current setting.  The problem with the former is it could be annoying to the
user.
These are basically toggles to change the preference.  How quickly they affect
the page is up for debate (change at load time/next page load).

Ideally they would take affect right away.  This way they could be used as
start/stop animations/applets buttons, and a start/stop auto-load images button.
Theoretically this could apply to any bug #7380 option, but I'd only expect it
to be implementing for useful boolean (checkbox) options which include:

Auto-Load Images, Animate Images, Enable Applets, Enable JavaScript, Enable
Popup Windows, Cookies, Background Sound
As an extension to this, how about the option for sites to skin mozilla? The
user would get a confirm box with something like "This site wishes to change the
look of Mozilla for windows in which it is loaded. Do you want this to happen?".
Plus a radio button:
 > This time only
 > Always for this site
 > Always for all sites

Lemming
Summary: UI buttons for temporary disabling. → [RFE] UI buttons for temporary disabling.
adding in RFE.
I've already mentioned chrome replacement in bug #7380, this bug does not cover
any prompting behaviour.
Although you could certainly have a button for chrome replacement - it just
wouldn't give prompts.
A Turn Images On & Off button on the toolbar would be nice for those of
us not on highspeed connections. Instead on being buried in the Edit /
Preferences/ yadda yadda yadda diggin Tab just to turn a simple feature
on or off seems a lil' bit pre-historic these days me tinx :)
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → INVALID
UI has changed quite a bit since this bug was filed....marking invalid
This has nothing to do with the new skin!
Status: RESOLVED → REOPENED
Reopening since the close comment makes no sense.  This is an RFE for something
which is not in the product yet, so it hardly matters what the UI does now.  To
my knowledge there is no product support for this at this point.
Resolution: INVALID → ---
Target Milestone: M14
*** Bug 19464 has been marked as a duplicate of this bug. ***
Move to M20.
As a fairly simple fix, how about making the 'Stop' button halt animations, 
etc, if it's pressed after the page has finished loading?  This is IE's 
behavior.
Adding helpwanted in keywords.  Maybe a net community person can do this.  
Keywords: helpwanted
Move to "Future" milestone.
Target Milestone: M20 → Future
Depends on: 7380
see also bug 42663
No longer depends on: 7380
bug 21623 is "Stop button should stop animations"
Since Don has left, Vishy is taking his bugs in bulk, pending reassignment.
thanks,
	Vishy
Assignee: don → vishy
Status: REOPENED → NEW
leger is no longer @netscape.com
changing qa contact to default for this component
QA Contact: leger → doronr
I think this bug and bug 20826 are the same.
i hope this is a dupe, because this bug report is unreadable.

*** This bug has been marked as a duplicate of 20826 ***
Status: NEW → RESOLVED
Closed: 20 years ago19 years ago
Resolution: --- → DUPLICATE
I've no idea what's unreadable about this report, but I'll agree it's a
duplicate.  I think this report would have been better to leave open though for
many reasons.
How about adding a way to disable the Flash plugin?
Verified dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.