Closed Bug 1515078 Opened 11 months ago Closed 10 months ago

Add opt in/out UX for Pocket+New Tab

Categories

(Firefox :: New Tab Page, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 66
Iteration:
66.3 - Jan 7 - 20
Tracking Status
firefox66 --- fixed

People

(Reporter: andreio, Assigned: andreio)

References

Details

(Keywords: github-merged)

User Story

Discussion https://docs.google.com/document/d/1xafaxvJ8UEZovRm3RX9p7MKnsv51G3hio2E0S0c-2Uw/edit

Wireframe https://www.figma.com/file/LulVDPDFnbh5XIxSxpW7bBQI/Preferences?node-id=0%3A1

Attachments

(4 files)

No description provided.
User Story: (updated)
Assignee: nobody → andrei.br92
Iteration: --- → 66.3 - Jan 7 - 20
The wireframe mocks have a few different versions, the latest is the "v3" page.

Attaching a screenshot in case.
Priority: -- → P1
Severity: normal → enhancement
Commit pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/35b5b9a35de3e8324100d5c11969a9a975c62753
Bug 1515078 - Add opt out UX in about:preferences for Pocket Newtab (#4642)
Blocks: 1520324
Status: NEW → RESOLVED
Closed: 10 months ago
Keywords: github-merged
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66

Steps to test:

  1. Set browser.newtabpage.activity-stream.discoverystream.config pref to {"enabled":true,"layout_endpoint":"https://getpocket.com/v3/newtab/layout?version=1&consumer_key=40249-e88c401e1b1f2242d9e441c4&layout_variant=dev-test-1"} in about:config
  2. Go to about:preferences#home
  3. Ensure you see a "Turn off content" button in the Firefox Home section
  4. Click it. Ensure you no longer see the pocket new tab experiment on existing tabs and new tabs

Test Results:

Verified on :

FF Nightly Version - 66.0a1 (2019-01-17)

OS - Mac / Windows 10 Pro N

Looks good to me.

Status: RESOLVED → VERIFIED
Blocks: 1521084
Pushed by aoprea@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3e975e4b3558
Add opt out UX in about:preferences for Pocket Newtab r=Mardak
Commit pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/2a4c65cd29867fdd152a03bf6fe2cd9a9eb05d76
Bug 1515078 - Use PreferenceExperiments API to unenroll from Pocket Newtab experiment (#4677)
Blocks: 1521093
Status: VERIFIED → RESOLVED
Closed: 10 months ago10 months ago

Re-testing this bug due to new implementation changes.

Test Failed. After QA steps, New Tab experiment doesn't switch back to default experience.

QA Results:

Tested on :

FF Nightly Version : 66.0a1 (2019-01-22)

OS : Mac , Windows 10 Pro

Steps to Reproduce:

  1. Go to about:config and Set browser.newtabpage.activity-stream.discoverystream.config pref to {"enabled":true,"layout_endpoint":"https://getpocket.com/v3/newtab/layout?version=1&consumer_key=40249-e88c401e1b1f2242d9e441c4&layout_variant=dev-test-1"}
  2. Go to about:preferences#home
  3. Ensure you see a "Turn off content" button in the Firefox Home section
  4. Click Turn off content--> Open New Tab and also check already opened New Tab

Actual Result :
New Tab experience persists.

Expected Result:
Default new tab version on existing tabs and new tabs is expected.

Severity: enhancement → normal
Flags: needinfo?(andrei.br92)

This is expected behavior. We check if the user is enrolled in an experiment in order to properly remove them but we optimistically change the UI in about:preferences if the pref is turned on and when you click the button to disable.
I will be working on a method to fake enrollment through asrouter-debuger so we can properly test this feature.

Flags: needinfo?(andrei.br92)

Is there a separate bug you’re tracking for the method that you’ve mentioned, so this bug can be closed.

Severity: normal → enhancement
Flags: needinfo?(andrei.br92)
Flags: needinfo?(andrei.br92)

Closing as verified.

Status: RESOLVED → VERIFIED
Depends on: 1527626
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.