Closed Bug 1527626 Opened 1 year ago Closed 1 year ago

Large blank area in the search results on Preferences when searching for 'pass'

Categories

(Firefox :: Preferences, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 67
Iteration:
67.2 - Feb 11 - 24
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- unaffected
firefox66 + verified
firefox67 --- verified

People

(Reporter: jaws, Assigned: andreio)

References

Details

(Keywords: github-merged, regression)

Attachments

(3 files)

Attached image 2019-02-13_1013.png

Large blank area in the search results on Preferences when searching for 'pass'. See attached screenshot.

This is not reproducible on mozregression but multiple people have reported it.

It looks like the cause is that #homeContentsGroup has an inline style of visibility: hidden which is overriding the visiblity: collapse that is applied through the .visibly-hidden class.

Keywords: regression
Priority: -- → P1
Flags: needinfo?(edilee)
Assignee: nobody → andrei.br92
Flags: needinfo?(edilee)

This will affect 66 users who are in the experiment.

Blocks: 1515078
No longer blocks: 1520324
Blocks: 1528119
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Iteration: --- → 67.2 - Feb 11 - 24
Keywords: github-merged
Blocks: 1512725

Gavin, Can you add some QA steps for this?

Brahmini can you QA?

Flags: needinfo?(gsuntop)
Flags: needinfo?(bnagabandi)

I didn't work on this one, sorry.

Flags: needinfo?(gsuntop)

Ed, can you add in steps for QA?

Flags: needinfo?(edilee)

QA steps:

  1. visit about:preferences
  2. with the in-content search box near the top, type "pass"
  3. make sure there's not a lot of empty space between sections (it should show main sections: Network Settings then Login & Passwords then Certificates)

note: in step 3 before the fix, it looks like only Network Settings shows up because there's so much empty space before the next one

I have verified in Nightly 67.0a1 on Mac OS 10.14.3, there is no longer a large space between the Network Settings and Login & Password sections

Flags: needinfo?(bnagabandi)

Comment on attachment 9044270 [details]
Bug 1527626 - Large blank area in the search results on Preferences when searching for pass

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

None

User impact if declined

ugly UX in pref search

Is this code covered by automated tests?

Yes

Has the fix been verified in Nightly?

Yes

Needs manual test from QE?

Yes

If yes, steps to reproduce

(see comment 9)

List of other uplifts needed

None

Risk to taking this patch

Low

Why is the change risky/not risky? (and alternatives if risky)

this is a small patch that affects styling. It is very easy to verify and is isolated to the preferences pane

String changes made/needed

Attachment #9044270 - Flags: approval-mozilla-beta?

Comment on attachment 9044270 [details]
Bug 1527626 - Large blank area in the search results on Preferences when searching for pass

Planned work for pocket/new tab. Verified in Nightly.
OK for beta uplift, should land for beta 9.
Landing order: bug 1519879, bug 1525494, bug 1526861, bug 1524669, bug 1527195, bug 1525391, bug 1527347, bug 1525366, bug 1527626, bug 1527397, bug 1518258, bug 1527701, bug 1527370.

Attachment #9044270 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: needinfo?(edilee)
Duplicate of this bug: 1527137

(In reply to Wolasi from comment #10)

I have verified in Nightly 67.0a1 on Mac OS 10.14.3, there is no longer a
large space between the Network Settings and Login & Password sections

Can you please verify this issue on Firefox 66 Beta 9 (https://archive.mozilla.org/pub/firefox/candidates/66.0b9-candidates/build1/)?

Flags: qe-verify+
Flags: needinfo?(wkonu)

I have verified in Beta 66.0b9 on Mac OS 10.14.3, there is no longer a large space between the Network Settings and Login & Password sections.

Flags: needinfo?(wkonu)
Whiteboard: [qa-triaged]
Flags: qe-verify+

(In reply to Wolasi from comment #16)

I have verified in Beta 66.0b9 on Mac OS 10.14.3, there is no longer a large
space between the Network Settings and Login & Password sections.

Thanks for verifying this!

QA Whiteboard: [qa-triaged]
Whiteboard: [qa-triaged]
You need to log in before you can comment on or make changes to this bug.