Closed Bug 1515760 Opened 2 years ago Closed 5 months ago

Implement imagesrcset and imagesizes attributes on link rel=preload

Categories

(Core :: DOM: Core & HTML, enhancement, P3)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1618295

People

(Reporter: domfarolino, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36

Steps to reproduce:

It is useful for the UA to be able to preload responsive images. Spec PRs and discussions:

 - https://github.com/w3c/preload/issues/120 (Initial discussion)
 - https://github.com/whatwg/html/pull/4048 (HTML Standard PR)
 - https://github.com/w3c/preload/pull/134 (Preload Spec PR (minor))
I am going to assign the "Core: Layout: Images, Video, and HTML Frames" component for it.
Component: Untriaged → Layout: Images, Video, and HTML Frames
Product: Firefox → Core
Preloading is DOM code, technically, I guess.
Status: UNCONFIRMED → NEW
Component: Layout: Images, Video, and HTML Frames → DOM: Core & HTML
Ever confirmed: true
See Also: → 1222633
Dragana might have a better idea of if there's a plan for this.
Flags: needinfo?(dd.mozilla)

rel=preload is not implemented yet. This needs to wait...

Depends on: 1394778
Flags: needinfo?(dd.mozilla)
Priority: -- → P3
Depends on: 1600118
No longer depends on: 1394778
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1618295
You need to log in before you can comment on or make changes to this bug.