Closed Bug 1516437 Opened 3 years ago Closed 2 years ago

Startup crash when build with Mojave SDK (nsBaseWidget not thread-safe)

Categories

(Core :: Widget: Cocoa, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1515183

People

(Reporter: wcpan, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:64.0) Gecko/20100101 Firefox/64.0

Steps to reproduce:

Build firefox with Mojave SDK.


Actual results:

It crashes immediately.


Expected results:

It should not crash.
Attached file stack.txt
Stack from lldb.
Attached file warning.txt
Some messages which likely related to this problem.
Status: UNCONFIRMED → NEW
Rank: 10
Ever confirmed: true
Priority: -- → P2
Priority: P2 → P3
Depends on: 1515183

Hey,

I am facing the same issue while building on mojave. Is there any way to work around and run firefox?

while building running a debug build

(In reply to malikanshul29 from comment #3)

Hey,

I am facing the same issue while building on mojave. Is there any way to work around and run firefox?

You should build with an SDK version lower than 10.14. As of the landing of bug 1500504 you should be getting an error message at compile time when trying to compile with the 10.14 SDK.

Even post bug 1500504, my build completes, but I get this assertion hit.

Does the patch in bug 1515183 help?

In fact I think this bug might just be a straight up dupe of bug 1515183.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1515183
You need to log in before you can comment on or make changes to this bug.