Closed Bug 151688 Opened 22 years ago Closed 20 years ago

Allow a browse to set email storage directory.

Categories

(SeaMonkey :: MailNews: Account Configuration, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.7beta

People

(Reporter: lbneal, Assigned: Stefan.Borggraefe)

References

Details

Attachments

(1 file)

Mozilla 1.1a

Presently must remember exact path to selected and/or consolidated email 
directory.

Should be able to browse the computer and select the directory.
This seems to be an RFE for a directory picker button in the "Mail & Newsgroups
account settings" (in the "Edit" menu).

When you currently select "Server Settings" for one of your accounts - or select
the "Local Folders" entry - you can choose a directory where you want to store
your mail.
But you have to type the path to that directory by hand, there is no directory
picker dialog that helps you find it.

Did not find another bug about this...
*** Bug 171510 has been marked as a duplicate of this bug. ***
-> all/all (based on duplicate)

Feel free to search if this has been filed before...
OS: Windows NT → All
Hardware: PC → All
Reporter: Can you reproduce this bug with a recent build of Mozilla (for
example, 1.4rc1)? 

If so, then please comment again with details. 
If not, then please resolve this bug as WORKSFORME. Thanks.
Confirming still present in:
 Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529
Please review, check if other OS's exhibit, confirm, and set a target.

JG
Status: UNCONFIRMED → NEW
Ever confirmed: true
mozilla@jguk.org, waht do you mean by "set a target"??
The "Target Milestone" is _only_ used by the developer taking a bug and should
not be changed by anybody else.

Also, this bug report is about a feature to be added. It has not been added on
Linux yet, so it is very unlikely to exist on any other OS. (In case that is not
enough for you: no, ther is no directory picker button on Windows, too.) 
*** Bug 221206 has been marked as a duplicate of this bug. ***
Adding 4xp keyword based on the bug I just duped.
Keywords: 4xp
*** Bug 228078 has been marked as a duplicate of this bug. ***
Depends on: 81572
Blocks: 81572
No longer depends on: 81572
Attached patch PatchSplinter Review
This basically takes the fix for bug 232433 and makes it available to
am-server.xul, too.

I furthermore changed localFolderPicker.label from "Location of Local Folders:"
to "Select Local Directory". "Local Folders" is just the default name of the
special local account. This name can be changed by the user. So I think this
string shouldn't appear in the dialog title. "Local directory" is the label of
the path the user selects with the browse-button and thus is more appropriate
to appear in the dialog title.
Assignee: racham → borggraefe
Status: NEW → ASSIGNED
Comment on attachment 141163 [details] [diff] [review]
Patch

Scott, could you please review? Do you think it's okay to use amUtils.js for
this function?
Attachment #141163 - Flags: review?(mscott)
Comment on attachment 141163 [details] [diff] [review]
Patch

this looks good to me. I found that you really need the fix for Bug #232443 for
the browse button to really be useful.
Attachment #141163 - Flags: review?(mscott) → review+
Attachment #141163 - Flags: superreview?(bienvenu)
Attachment #141163 - Flags: superreview?(bienvenu) → superreview+
I checkd this into the 1.7b trunk. Thanks for this patch, it's very useful.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.7beta
*** Bug 236990 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: