Move Thunderbird mozharness unittest configs out of m-c

RESOLVED FIXED in Thunderbird 67.0

Status

defect
RESOLVED FIXED
5 months ago
3 months ago

People

(Reporter: rjl, Assigned: rjl)

Tracking

Trunk
Thunderbird 67.0
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

Assignee

Description

5 months ago
In bug 1506715 comment 8, Geoff Brown [:gbrown] stated:
> The mochitest harness changes are fine, but I think you need a clearer
> separation of thunderbird from the mozharness configuration. Ideally, there
> shouldn't be thunderbird mozharness configuration in mozilla-central.

The end result of this bug is that thunderbird_extra.py is moved to comm/mozharness/unittests and thunderbird_buildbot.py is completely removed as it's obsolete.
Assignee

Updated

5 months ago
Depends on: 1506715
Assignee

Comment 1

4 months ago
First step in moving Thunderbird mozharness unittest configurations out of
M-C. This adds the comm/mozharness directory to the mozharness test archive
under mozharness/configs/comm so that they can be access later by
desktop_unittest.py.
Assignee

Comment 2

4 months ago
Moving TB specific mozharness unittest configurations out of mozilla repository.
Assignee

Comment 3

4 months ago
Adds the necessary taskcluster and mozharness configuration for Thunderbird
Mochitests.
Note that the addition of "all_mochitest_suites" in thunderbird_extra.py will
replace the inherited list of tests from mozilla.

Depends on D16375
Assignee

Comment 4

4 months ago

The try runs for this series of patches look promising.

try:

try-comm-central:

Flags: needinfo?(geoff)

The Mochitests failed, but I don't think it was a CI issue.

I had a better test run with some prefs changed, so you're right.

https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=1756a9495af2428bdb1072a878ef5a819efe12cb

Flags: needinfo?(geoff)
Duplicate of this bug: 1507317
Attachment #9036080 - Attachment description: Bug 1517298 - Add comm mozharness configs to mozharness test archive. r?gbrown → Bug 1517298 - Add comm mozharness configs to mozharness test archive.
Assignee

Comment 7

4 months ago
thunderbird_buildbot.py is no longer necessary now that Thunderbird builds
on Taskcluster.
thunderbird_extra.py is moved into comm-*.

Comment 8

4 months ago
Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/integration/autoland/rev/8431bedf934c
Add comm mozharness configs to mozharness test archive. r=firefox-build-system-reviewers,mshal

Comment 9

4 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 66.0
Assignee

Comment 10

4 months ago

reopening since there is more to land on this bug.

Status: RESOLVED → REOPENED
Keywords: leave-open
Resolution: FIXED → ---

Comment 11

4 months ago
Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/comm-central/rev/655c34c266f6
Move TB unittest configs into comm repository. r=darktrojan
https://hg.mozilla.org/comm-central/rev/3c26a13818d0
TB Mochhitest configuration for taskcluster. r=darktrojan
Assignee

Comment 12

4 months ago

Developer requested that mochitests only run on optimized builds for right
now.

Comment 13

3 months ago
Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/integration/autoland/rev/870a3cdb1a99
Remove Thunderbird unittest configs from mozilla-*. r=jmaher
Assignee

Updated

3 months ago
Keywords: checkin-needed
Target Milestone: Thunderbird 66.0 → Thunderbird 67.0
Version: 66 → Trunk
Assignee

Updated

3 months ago
Keywords: leave-open

Comment 14

3 months ago
bugherder
Status: REOPENED → RESOLVED
Last Resolved: 4 months ago3 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Assignee

Comment 15

3 months ago

D17987, attachment 9039938 [details] needs to be committed.

Status: RESOLVED → REOPENED
Keywords: checkin-needed
Resolution: FIXED → ---

Comment 16

3 months ago

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/2320b1ccb435
Set mochitests to only run for optimized builds. r=darktrojan

Status: REOPENED → RESOLVED
Last Resolved: 3 months ago3 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.