Teach local artifact builds how to use PGO binaries

RESOLVED FIXED in Firefox 66

Status

defect
RESOLVED FIXED
6 months ago
5 months ago

People

(Reporter: nalexander, Assigned: chmanchester)

Tracking

(Blocks 1 bug, {in-triage})

Trunk
mozilla66
Dependency tree / graph

Firefox Tracking Flags

(firefox66 fixed)

Details

Attachments

(1 attachment)

Sometimes it's useful to have a local artifact build use Nightly binaries rather than opt binaries; similarly, it's sometimes useful to have a local artifact build use pgo binaries rather than opt binaries.  This ticket tracks the latter (but see Bug 1445343 for the Nightly binaries, too).

This is in response to https://groups.google.com/d/msg/mozilla.dev.platform/0dYGajwXCBc/J6q1_7IzBgAJ.

Updated

5 months ago
Keywords: in-triage
Assignee

Comment 1

5 months ago

I will look into this.

Assignee: nobody → cmanchester

awesome, thanks Chris!

Assignee

Updated

5 months ago
Duplicate of this bug: 1517533

Comment 5

5 months ago
Pushed by cmanchester@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/29429b3bef3e
Extend artifact builds to find and download artifacts from pgo builds when MOZ_PGO is set. r=nalexander

Comment 6

5 months ago
bugherder
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Assignee

Updated

5 months ago
Duplicate of this bug: 1495538
Blocks: 1519012
You need to log in before you can comment on or make changes to this bug.