Last Comment Bug 152015 - layout regression tests should have fewer asserts
: layout regression tests should have fewer asserts
Status: RESOLVED WORKSFORME
:
Product: Core Graveyard
Classification: Graveyard
Component: Tracking (show other bugs)
: Trunk
: x86 Windows 98
: -- normal (vote)
: ---
Assigned To: Bernd
: chris hofmann
Mentors:
Depends on: 125090 127544 133989 139568 143512 151285 151582 151590 151883 151888 151983 153679
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-15 06:26 PDT by Bernd
Modified: 2016-07-15 12:13 PDT (History)
3 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Bernd 2002-06-15 06:26:31 PDT
This bug tracks the assertions revealed by the layout regression tests. In
principle this list should shrink, but this is not a bug to silence the
messages, but to track those problems. Assertions caused by the layout
regression tests have a positive side: there is a testcase to trigger them, and
a negative somebody changed the source and did not pay attention to the problems
his changes may have caused. Please add new asserts to the bug if you encounter
them.

bug 139568
nsFrameManager::GenerateStateKey didn't find content by type!: 'index > -1'
bug 125090
Bad tag enum passed to CNavDTD::IntTagToStringTag()!!: 
nsDependentString must wrap a non-NULL buffer: 'aPtr'
bug 143512
attribute encountered -- this shouldn't happen unless the attr
ibute was not part of a start tag!: 'Error'
bug 151582
AddPrincipal: 'Not Reached', file nsXULDocument.cpp
bug 151285
damage area expanded incorrectly: 'PR_FALSE'
bug 133989
containing block height must be constrained: 'containingBlockHeight !=
NS_AUTOHEIGHT'
bug 151883
parent frame but no child frame or undisplayed entry: '!parentFrame
bug 127544
CellIterator program error: 'PR_FALSE
bug 151888
nsVoidArray::ElementAt(index past end array) - note on bug 96108
bug 151983
imgLoader::LoadImage -- NULL URI pointer
bug 151590
data loss - incomplete row needed more height than available, on top of page:
'desiredSize.height <= rowReflowState.availableHeight'
Comment 1 Bernd 2002-06-23 00:47:51 PDT
bug 153679
 aWidgetView must have a widget: 'nsnull != widget'
Comment 2 Bernd 2008-03-02 00:34:56 PST
I verified all bugs on the dependency list, they are fixed. As we do not use the rtest frame work anymore, I close this bug as wfm

Note You need to log in before you can comment on or make changes to this bug.