Closed Bug 1520854 Opened 9 months ago Closed 9 months ago

text-color in AS dark theme regressed to grey by DS change

Categories

(Firefox :: New Tab Page, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 66
Iteration:
66.3 - Jan 7 - 20
Tracking Status
firefox-esr60 --- unaffected
firefox64 --- unaffected
firefox65 --- unaffected
firefox66 --- fixed

People

(Reporter: dmose, Assigned: dmose)

References

Details

(Keywords: github-merged, regression)

User Story

How to test:

* In a clean profile, set your computer's OS to use dark theme (on Mac, this is System Preferences -> General).
* Open a new tab
* For the pocket cards, the title and excepts should be a legible light grey

Then, to ensure that this fix hasn't regressed the original thing it was intended to address.

* Reset your computer's OS theme use a light theme
* go to about:config
* search for stream.config
* set that preference to {"enabled":true,"layout_endpoint":"https://getpocket.com/v3/newtab/layout?version=1&consumer_key=40249-e88c401e1b1f2242d9e441c4&layout_variant=dev-test-all"}
* open a new tab

Verify that the text in the title of the Trending Stories list items is #0C0C0D

Attachments

(2 files)

User Story: (updated)
Blocks: 1521093
Keywords: github-merged
Priority: -- → P1
Duplicate of this bug: 1521156
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Attached image QA Result - 1520854.png

QA Results:

Tested on :

FF Nightly version : 66.0a1 (2019-01-18)
OS : Mac and Windows 10

Attaching screenshot of the result "QA Result - 1520854.png"

Looks good to me.

Closing bug as verified.

Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.