Bug 1520948 (angle-68)

Update ANGLE in Firefox 68

RESOLVED FIXED in Firefox 68

Status

()

enhancement
P1
major
RESOLVED FIXED
4 months ago
14 days ago

People

(Reporter: jgilbert, Assigned: jgilbert)

Tracking

(Regressed 1 bug)

unspecified
Future
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66 wontfix, firefox67 wontfix, firefox68 fixed)

Details

(Whiteboard: gfx-noted)

Attachments

(3 attachments)

Assignee

Description

4 months ago
No description provided.
Assignee

Updated

4 months ago
Depends on: 1520953
Assignee

Updated

4 months ago
Whiteboard: gfx-noted
Blocks: angle-66
Priority: -- → P3
Assignee

Updated

4 months ago
Summary: Update ANGLE to chromium/3626 (Chrome Beta 72) in Firefox 66 → Update ANGLE to chromium/3626 (Chrome Beta 72) in Firefox 67
Assignee

Updated

4 months ago
Alias: angle-66 → angle-67
Assignee

Updated

4 months ago
No longer blocks: angle-66
Assignee

Updated

4 months ago
Depends on: 1494474
Assignee

Updated

3 months ago
Alias: angle-67 → angle-68
Severity: normal → major
Priority: P3 → P2
Summary: Update ANGLE to chromium/3626 (Chrome Beta 72) in Firefox 67 → Update ANGLE in Firefox 68
Target Milestone: --- → Future
Assignee

Updated

2 months ago
Depends on: 1536307
Assignee

Updated

2 months ago
Depends on: 1536308
Assignee

Updated

2 months ago
Depends on: 1536311
Assignee

Updated

2 months ago
Depends on: 1539648
Assignee

Comment 2

a month ago
  • Support DEFFILE in update-angle.py.
  • Add standalone --check
Attachment #9051473 - Attachment description: Bug 1520948 - Update ANGLE to chromium/3683..moz/firefox-68. → Bug 1520948 - Update ANGLE to chromium/3729..moz/firefox-68.
Assignee

Comment 3

a month ago

Depends on D23772

Assignee

Updated

a month ago
Priority: P2 → P1
Blocks: 1414961
Assignee

Comment 4

a month ago

Linking error on MinGW:
https://treeherder.mozilla.org/#/jobs?repo=try&selectedJob=240015576&revision=ccb7d15fa4315748458db1b5d2d5efef6ed1c685

Please advise!
It seems to link fine on all other configurations. Why is only MinGW complaining about duplicate symbols here?

Flags: needinfo?(tom)
Flags: needinfo?(jacek)

Comment 5

a month ago

As far as I can see, they are ideed duplicated, but one of places where it's defined is a .def file used for libGLESv2.dll. The importlib is linked as if it was a static lib to be included inside linked library, it's just referenced as |../libGLESv2/liblibGLESv2.a|. I guess that using -l (eg. -L../libSLESv2 -l libGLESv2) could help. AFAICS, moz.build file uses USE_LIBS for it, I lost track of how those work in moz.builds.

Flags: needinfo?(jacek)
Assignee

Comment 6

a month ago

I'm gonna try building with -DANGLE_USE_EGL_LOADER. I don't see how the code is supposed to /not/ have duplicate symbols without it, even though we didn't use to need it.

Flags: needinfo?(tom)
Assignee

Comment 7

a month ago

Try looking greenish.

I'll attempt to land this on Monday.

Updated

a month ago
Regressions: 1546440
Assignee

Updated

29 days ago
Blocks: angle-68-2
Assignee

Updated

29 days ago
Regressions: 1546491

Comment 10

29 days ago

Hmm, since this landed, I can't compile Thunderbird any more :-(

0:15.70 c:/mozilla-source/comm-central/gfx/angle/checkout/src\libANGLE/renderer/d3d/d3d11/converged/CompositorNativeWindow11.h(15,10): fatal error: 'dispatcherqueue.h' file not found

https://searchfox.org/mozilla-central/rev/ec489aa170b6486891cf3625717d6fa12bcd11c1/gfx/angle/checkout/src/libANGLE/renderer/d3d/d3d11/converged/CompositorNativeWindow11.h#15

and

https://searchfox.org/mozilla-central/rev/ec489aa170b6486891cf3625717d6fa12bcd11c1/gfx/angle/checkout/src/libANGLE/renderer/d3d/d3d11/Renderer11.cpp#67

EDIT: Commenting out
https://searchfox.org/mozilla-central/rev/ec489aa170b6486891cf3625717d6fa12bcd11c1/gfx/angle/checkout/src/common/platform.h#49

does not help, neither does changing this to #undef ANGLE_ENABLE_WINDOWS_STORE.

TB builds are working fine in automation and a colleague can also compile without problem. So I must be doing something wrong.

Jeff, any hints?

Flags: needinfo?(jgilbert)

Comment 11

29 days ago

Oh, I see, bug 1546491.

Flags: needinfo?(jgilbert)
Assignee

Comment 12

28 days ago

Yep, you got it! You'll need at least the Windows 10 SDK 10.0.17134.0.

Regressions: 1546891
Assignee

Updated

16 days ago
No longer blocks: 1414961

Small perf win noticed:

== Change summary for alert #20874 (as of Thu, 09 May 2019 03:44:06 GMT) ==

Improvements:

2% tart windows10-64-shippable-qr opt e10s stylo 2.46 -> 2.41

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=20874

You need to log in before you can comment on or make changes to this bug.