Bump clang-cl to 8.0.0 release branch for arm64 support

RESOLVED FIXED in Firefox 66

Status

enhancement
RESOLVED FIXED
5 months ago
5 months ago

People

(Reporter: dmajor, Assigned: dmajor)

Tracking

Trunk
mozilla66
Dependency tree / graph

Firefox Tracking Flags

(firefox66 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

5 months ago

Bug 1512822 will require that we use at least LLVM 8.0.0 rc1.

The sidebar on llvm.org's front page is currently projecting:

8.0.0:
Jan 16: Branch point, rc1
Feb 6: rc2
Feb 27: final

(Though historically the dates have not always been exact.)

According to the Firefox release calendar, we have merge days on 2019-01-28 (Fx67) and 2019-03-18 (Fx68).

I propose that in the first days of Firefox 67, we take whatever LLVM RC is current, and later within 67 pick up the final release.

Assignee

Updated

5 months ago
Depends on: 1521133
Assignee

Comment 1

5 months ago

Comment 2

5 months ago

I'm getting the following linker error in libxul when trying to build with rc1 and ThinLTO:

LLVM ERROR: Associative COMDAT symbol '??_7MaxExpSink@?A0xC8782BCA@icu_63@@6B@' does not exist.

Assignee

Comment 3

5 months ago

(In reply to Michael Woerister from comment #2)

I'm getting the following linker error in libxul when trying to build with
rc1 and ThinLTO:

LLVM ERROR: Associative COMDAT symbol
'??_7MaxExpSink@?A0xC8782BCA@icu_63@@6B@' does not exist.

Do you have a link to a try push? (Not necessary but it would be the most concise way to reproduce your state.) Otherwise, can you share your mozconfig, LLVM and Mozilla revisions, and any patches you have applied?

Attachment #9037643 - Attachment description: Bump clang-cl to 8.0.0 release branch → Bump clang-cl to 8.0.0 rc1

Comment 6

5 months ago
Pushed by dmajor@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bb99a5af0154
Bump clang-cl to 8.0.0 rc1 r=glandium

Comment 7

5 months ago
bugherder
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Assignee: nobody → dmajor
Assignee

Updated

5 months ago
Blocks: 1516543

Updated

5 months ago
Duplicate of this bug: 1512921
Assignee

Updated

5 months ago
Depends on: 1524087
You need to log in before you can comment on or make changes to this bug.