Titlebar window control placement on left despite Ubuntu 18.10 setting specifying the right

RESOLVED FIXED in Firefox 66

Status

()

defect
RESOLVED FIXED
4 months ago
3 months ago

People

(Reporter: ke5trel, Assigned: stransky)

Tracking

(Blocks 1 bug, {regression})

66 Branch
mozilla66
Unspecified
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox64 unaffected, firefox65 unaffected, firefox66 fixed)

Details

Attachments

(2 attachments)

Reporter

Description

4 months ago

Ubuntu 18.10 Tweaks app indicates titlebar window controls placement is "Right" but actual placement is on left.

Workaround is to create about:config integer setting ui.GtkCSDReversedPlacement = 0 and restart.

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=529a105310435244ef67c078a810ad92b22d9327&tochange=7d151a27de64cce8b0ed96443c1888656341e420

Regressed by: Bug 1433667

Duplicate of this bug: 1521436
Assignee

Updated

4 months ago
Assignee: nobody → stransky
Assignee

Comment 2

4 months ago

Hm, I'm unable to reproduce on clean Ubuntu 18.10 installation, the buttons are on correct side and changes according the Tweaks app. Perhaps I miss something.

Reporter

Comment 3

4 months ago

This is caused by appmenu in the button-layout which is added by Tweaks -> Top Bar -> Application Menu -> OFF which persists even after turning it back ON.

org.gnome.desktop.wm.preferences button-layout
Default: ':minimize,maximize,close'
Breaks placement: 'appmenu:minimize,maximize,close'
Also breaks placement: ':appmenu,minimize,maximize,close'

Assignee

Updated

4 months ago
Depends on: 1519606
Assignee

Comment 4

4 months ago

Thanks a lot!

Assignee

Comment 5

4 months ago

Use only ':' separator instead of 'menu:' to place titlebar buttons as the menu may not be always present.

Assignee

Updated

4 months ago
Keywords: checkin-needed

Comment 6

4 months ago

Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c4ef82395d7c
[Linux/Gtk] Use ':' separator to place titlebar buttons left/right, r=dao

Keywords: checkin-needed

Comment 7

4 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Duplicate of this bug: 1522165
You need to log in before you can comment on or make changes to this bug.