Web Authentication - Support additional Windows Hello Algorithms

RESOLVED FIXED in Firefox 66

Status

()

defect
P1
normal
RESOLVED FIXED
7 months ago
7 months ago

People

(Reporter: jcj, Assigned: akshay.sonu)

Tracking

(Blocks 1 bug)

66 Branch
mozilla66
Unspecified
Windows 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66 fixed)

Details

(Whiteboard: [webauthn])

Attachments

(1 attachment)

Windows Hello supports more algorithms than for other platforms, and apparently requires some additional ones [2] for Make Credential to function. These aren't enabled currently because of bad interactions at least one test [1], depending on resolution of bug 1409220.

It's unclear whether 1409220 is a dependency for this fix or not.

[1] https://searchfox.org/mozilla-central/source/dom/webauthn/tests/test_webauthn_make_credential.html#169
[2] https://phabricator.services.mozilla.com/D17363

Attachment #9038603 - Attachment description: Bug 1508115 - Web Authentication - Support Windows Hello → Bug 1522145 - Web Authentication - Support Windows Hello
Attachment #9038603 - Attachment description: Bug 1522145 - Web Authentication - Support Windows Hello → Bug 1522145 - Web Authentication - Support additional Windows Hello Algorithms
Pushed by jjones@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6b7bc4002311
Web Authentication - Support additional Windows Hello Algorithms r=keeler
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Duplicate of this bug: 1409220
You need to log in before you can comment on or make changes to this bug.