Closed Bug 1522795 Opened 9 months ago Closed 3 months ago

Upgrade Android gradle plugin to 3.4.*

Categories

(GeckoView :: General, defect, P3)

Unspecified
All
defect

Tracking

(firefox68 wontfix, firefox69 wontfix, firefox70 fixed)

RESOLVED FIXED
mozilla70
Tracking Status
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- fixed

People

(Reporter: sebastian, Assigned: Agi)

References

(Depends on 1 open bug, )

Details

Attachments

(1 file)

Upgrade to 3.2.1 is happening in Bug 1515248.

Version 3.3 requires:

  • Gradle 4.10.1 or higher.
  • SDK Build Tools 28.0.3 or higher.

@nalexander: FYI filed this as a separate bug since bug 1515248 seems to be far along already.

Also filed an A-C issue:
https://github.com/mozilla-mobile/android-components/issues/1745

I'm in no hurry to update A-C (or any app) though.

Flags: needinfo?(nalexander)
Depends on: 1521337
Flags: needinfo?(nalexander)

(In reply to Sebastian Kaspari (:sebastian; :pocmo) from comment #1)

I'm in no hurry to update A-C (or any app) though.

P3 if there is no hurry.

Depends on: 515248
Priority: -- → P3

I just finished up nalexander 3.2.1 patch, so since I'm the area I'm doing this too.

Assignee: nobody → agi
Duplicate of this bug: 1567953
Summary: Upgrade Android gradle plugin to 3.3 → Upgrade Android gradle plugin to 3.4.*
Pushed by asferro@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/90e13eecc416
Update android gradle plugin to 3.4.2. r=nalexander
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

69=wontfix because I assume we don't need to uplift the Gradle plugin update to GV 69 Beta.

Regressions: 1571288
You need to log in before you can comment on or make changes to this bug.