[PREFS] Plain quoted text display prefs don't stick...

VERIFIED FIXED in M15

Status

MailNews Core
Backend
P2
normal
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: laurel, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-])

(Reporter)

Description

18 years ago
Using 1999092909m11 on NT 4.0
Assume this to be all platforms, but can't use this area of prefs on linux or
mac (other bugs)

The plain quoted text display prefs dont stick and don't write to prefs.js file.

1.  From messenger window Edit|Prefs|Mail and News.
2.  Change the value of style and size in the first prefs area captioned "Plain
quoted text beginning with '>' is displayed with".  Confirm OK to prefs dialog.
3.  Open prefs again and check the values you just modified.

Result:  Changes did not stick in Prefs UI, nor were changes written to prefs.js
(even on exit).
(Reporter)

Updated

18 years ago
QA Contact: lchiang → laurel
accepting.  marking all milestone 11.

Updated

18 years ago
Summary: [PREFS] Plain quoted text display prefs don't stick... → [DOGFOOD] [PREFS] Plain quoted text display prefs don't stick...

Comment 2

18 years ago
IMO prefs have to stick for dogfood
since this is dogfood, I'm focusing on it right now.

Updated

18 years ago
Whiteboard: [PDT-]

Comment 4

18 years ago
Putting on the [PDT-] radar
this bug reveals a hole in the nsPrefWindow architecture:  we don't handle prefs
that are represented with the html select widget.  (radio buttons, check boxes,
text inputs work.)

I'll work on getting the it to work for these two mailnews prefs, then I'll sweep
through the rest of the prefs xul and fix other cases.

adding matt fisher to the cc list, since I'm sure he's got a bunch of bugs that
relate to this.

since this affects several prefs not saving or reflecting the correct value, I'd
say make this a PDT+.

either way, I'll continue working on it tomorrow.
really adding matt this time.

Updated

18 years ago
Blocks: 16950
Depends on: 15476
adding dependency on 15476
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
fixed.

matt, I added the necessary changes to allow html select widgets to reflect
prefs.

right now, only int prefs work.  the other prefs types will assert like made when
you try to use them.

see pref-mailnews.xul to see how to use it.

if you end up needing the other pref types before I fix it, raise the priority of
bug #17028
(Reporter)

Updated

18 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 9

18 years ago
This is still not working for the plain quoted text display prefs.  Sometimes
selected values will stick in UI, sometimes they won't. Particularly UI changes
to Style will not stick properly.  The same results happen whether I use a mouse
to select from the dropdown or whether I use arrow key selection.

As far as the pref changes being written to prefs.js, this isn't happening
correctly either.  Sometimes there will be a value change to mail.quoted_style,
but mail.quoted_size is never written.

Reopening...
(Reporter)

Comment 10

18 years ago
Oh, I'm using 1999-10-26-08m11 commercial builds over linux, mac, windows.

Updated

18 years ago
Resolution: FIXED → ---

Comment 11

18 years ago
Clearing FIXED resolution due to reopen.

Updated

18 years ago
Target Milestone: M11 → M12

Comment 12

18 years ago
M12

Comment 13

18 years ago
*** Bug 18027 has been marked as a duplicate of this bug. ***

Comment 14

18 years ago
Adding rhp since he didn't know about this bug.

Comment 15

18 years ago
Ben is actually doing the implementation side of this for libmime.

- rhp

Comment 16

18 years ago
Sorry, that I have to null alll your efforts, but I intend to make this
stylesheet based. I'm not sure, how we could add a pref writing a file.

Do we *really* need UI for this, if we have a stylesheet? Users caring about
such layout issues might want to know CSS / edit our stylesheets anyway, since
there'll be lots of other such "prefs" in the stylesheet.

Comment 17

18 years ago
We may need a UI for folks who are used to having this UI in 4.5.  Since we're
getting into UI now, I'll cc: jglick.

Comment 18

18 years ago
Agree with Lisa.  There should be a UI for this for users who have no clue how
to change their CSS file.

Updated

18 years ago
Target Milestone: M12 → M13

Comment 19

18 years ago
Not so fast with the stylesheet. How does this look to end-users? Why can't we
do what we did in 4.x? Stylesheets seem like a potential step backwards.

Comment 20

18 years ago
Phil,
> Stylesheets seem like a potential step backwards.
I don't think so. Stylesheets are a superset of the 4.x functionality, as the
user can define every bit of the display, not just the quotes. E.g. they might
fix bug #18427.
We will propably find an (from a coding perspective) unpretty, but easy way to
keep the 4.x UI w/o dropping stylesheets.
Target Milestone: M13 → M14
moving to m14.
Priority: P3 → P2
marking p2

Comment 23

18 years ago
I'd like to see the prefs stick for B1, but the implementation issues around
stylesheets can wait for a later milestone.

Comment 24

18 years ago
Putting dogfood in the keyword field.
Keywords: dogfood

Updated

18 years ago
Summary: [DOGFOOD] [PREFS] Plain quoted text display prefs don't stick... → [PREFS] Plain quoted text display prefs don't stick...
moving to m15.
Target Milestone: M14 → M15

Comment 26

18 years ago
We should release note this if not going to be fixed for Beta1.
Keywords: relnote
mail.quoted_style and mail.quoted_size are sticking.

the mail.citation_color pref (that is associated with the color picker is not.)

marking this bug fixed, and opening a new one on the mail.citation_color pref
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 28

18 years ago
Well, they stick and are written to prefs.js, but they don't work.  Will close
this and open a bug about functionality.

OK using 2000-03-07-09 commercial builds with linux rh6.0,NT 4.0 and mac OS 9.0
Status: RESOLVED → VERIFIED
(Reporter)

Updated

18 years ago
Keywords: relnote
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.