Closed Bug 15476 Opened 25 years ago Closed 25 years ago

[BLOCKER][DOGFOOD][PP] Mac, Linux - Unable to use html:select


(Core :: Layout: Form Controls, defect, P1)






(Reporter: hangas, Assigned: danm.moz)



(Whiteboard: [PDT+])

1) Launch Apprunner on Mac.
2) Choose File-New-Address Book Card menu item
3) The new address book card dialog appears, the first item in the dialog is an
html:select that does not allow you to modify the selection between the two
address books.

Note: if for some reason you do not have two address books, add one from the
Address Book window.  Open the address book from the tasks menu, select New
Address Book from the File menu.

This bug has been around for a while but was logged because I thought the zombie
window bug covered this too.
Blocks: 10925
Component: XP Toolkit/Widgets → HTML Form Controls
QA Contact: claudius → cpratt
Assignee: trudelle → karnaze
This is not an xptoolkit widget. reassigning.
Assignee: karnaze → kmcclusk
Reassigning to Kevin.
Assignee: kmcclusk → dcone
Tried on WIN32 Oct 5, 1999, 6:00PM build and it works.
Must be a Mac specific issue.

Don, reassigning to you.
Yes, this is Mac only.  I have been using select on Windows just fine, but with
Mac I am unable to choose a different option in the select.  The list of options
does not even leave the screen after I let go of the mouse button.
Summary: [PP] Unable to use html:select on Mac → [Dogfood][PP] Unable to use html:select on Mac
Marking as Dogfood.
Blocks: 15895
No longer blocks: 15895
*** Bug 15895 has been marked as a duplicate of this bug. ***
Summary: [Dogfood][PP] Unable to use html:select on Mac → [DOGFOOD][PP] Unable to use html:select on Mac
This bug also affects setting up new accounts (IMAP) on Mac which uses this
control (see duplicate bug) - users are unable to do so.  Per brade's request,
I'm ccing her on this bug.
Whiteboard: [PDT+]
Putting on PDT+ radar
Summary: [DOGFOOD][PP] Unable to use html:select on Mac → [DOGFOOD][PP] Unable to use html:select on Mac and Linux
Update summary: Linux too
*** Bug 16371 has been marked as a duplicate of this bug. ***
OS: Mac System 8.6 → All
Hardware: Macintosh → All
Summary: [DOGFOOD][PP] Unable to use html:select on Mac and Linux → [DOGFOOD][PP] Mac, Linux - Unable to use html:select
Severity: critical → blocker
Summary: [DOGFOOD][PP] Mac, Linux - Unable to use html:select → [BLOCKER][DOGFOOD][PP] Mac, Linux - Unable to use html:select
can we get some traction on this bug? this is now blocking you from being able
to create new accounts or setup mail for the first time.
*** Bug 16382 has been marked as a duplicate of this bug. ***
Assignee: dcone → danm
On the Mac, the events are not getting through to the message-pump for the
popup, so a select will not happen.. only when a dialog is used.  The combo box
and HTML select works in a normal window but not on a dialog.  Giving this to
the DanM since he knows about this and is looking for the answer...
you can work around this bug with the arrow keys, so there is a way to get
something done.

click on the select widget, and then up or down arrow through the choices.
adding alecf to the cc list, as he was asking about this bug.
aha! Is this a dupe of a bug I just found, #14131?
bug 14131 is for Linux.  Doesn't matter which one you mark as a dup.  If you
close this as a dup, need to make sure other bug has the right platform marked,
dogfood, etc.  Thanks.
Blocks: 17432
I tried the workaround of using the up and down arrow keys for selecting the
IMAP option in the Account Wizard. It looked like it was taken but I checked in
Account Settings and it actually saved it as POP.

This also effects the Copies and Folders select boxes. For instance I can choose
the "Sent" folder for the "Place a copy in" option. After pressing OK and
opening Account Settings again I notice that the changes were not saved. Even
after closing and opening the application.
The workaround w/ the arrow keys apparently no longer works.  Since this is the
case, can we get this for M11?
Priority: P3 → P1
Target Milestone: M12
P1 for M12.
Depends on: 14131
Probably a duplicate of 14131 (or at least, it should be fixed when that one is fixed.)
Linking them and leaving both open for now, since they have different, interesting
test cases.
Closed: 25 years ago
Resolution: --- → FIXED
Closed: 25 years ago25 years ago
*** This bug has been marked as a duplicate of 14131 ***
QA Contact: cpratt → elig
Whiteboard: [PDT+] → [PDT+] Verification blocked by 14131
QA Assigning to self for verification in cpratt's absence.

Verification blocked until 14131 is resolved/fixed. (It's been re-opened.)
Whiteboard: [PDT+] Verification blocked by 14131 → [PDT+]
Verified fixed/duplicate using 1999112408 builds on Win NT 4.0 SP5 and RH Linux
6.0/GNOME, with 1999112410 build on Mac OS 8.6. Also verified 16371, to be sure.

(Finally, also attempted to also verify duplicate bug 15895, but the UI no longer
uses a combo box.)
Note: This bug was marked a duplicate of 14131 (which has now been fixed and
verified) but the original scenario for this bug (for Address book New Card
Dialog) is still a problem, but is now on all platforms.  I will log a new bug
since this bug has other scenarios included. must have regressed since 11.24.99, as I most definitely checked the
scenario in question on all platforms!
No longer blocks: 17432
You need to log in before you can comment on or make changes to this bug.