Closed Bug 1523049 Opened 2 years ago Closed 1 year ago

Implement the context menu for the new rules view

Categories

(DevTools :: Inspector: Rules, enhancement, P3)

enhancement

Tracking

(firefox75 fixed)

RESOLVED FIXED
Firefox 75
Tracking Status
firefox75 --- fixed

People

(Reporter: gl, Assigned: gl)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

We can reuse the StyleInspectorMenu (https://searchfox.org/mozilla-central/source/devtools/client/inspector/shared/style-inspector-menu.js) to handle the context menus. We will need to implement the context menu handler (https://searchfox.org/mozilla-central/source/devtools/client/inspector/rules/rules.js#465-476) and getNodeInfo (https://searchfox.org/mozilla-central/source/devtools/client/inspector/rules/rules.js#337).

We can also look to the Changes panel which also recently implemented the context menu as well (https://bugzilla.mozilla.org/show_bug.cgi?id=1518512).

Duplicate of this bug: 1521528
Assignee: nobody → gl
Status: NEW → ASSIGNED
Pushed by gluong@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3b2e49d603db
Implement the context menu for the new rules view. r=rcaliman
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 75
You need to log in before you can comment on or make changes to this bug.