Closed Bug 1523578 Opened 9 months ago Closed 9 months ago

[Light theme] Tab titles are not visible in High Contrast mode with windows title bar accent color enabled

Categories

(Firefox :: Theme, defect, P1)

All
Windows 10
defect

Tracking

()

VERIFIED FIXED
Firefox 67
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- unaffected
firefox66 --- verified
firefox67 --- verified

People

(Reporter: tbabos, Assigned: dao)

References

Details

(Keywords: regression)

Attachments

(1 file)

[Affected versions]
Firefox 67.0a1
66.0b3

[Affected platforms]
Windows 10

[Steps to reproduce]

  1. Set a custom accent color from windows personalize settings
  2. Enable to show accent color on title bars
  3. Enable high contrast mode - black or white
  4. Launch Nighlty or Beta 66
  5. Open several new tabs
  6. Switch the firefox theme from [Customize] to Light

[Expected result]
Firefox theme should switch to Light theme correctly

[Actual result]
Tab titles and the "+" button to open new tabs are not visible while the opened window is focused: https://streamable.com/3jsyh

[Note]
The issue was found while verifying the fix for Bug 1516556

Assignee: nobody → dao+bmo
Blocks: 1516556
Status: NEW → ASSIGNED
Priority: -- → P1
OS: Windows → Windows 10
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6e27cc8c98da
In high contrast mode on Windows 10, don't override the lwtheme window background. r=ntim
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67

Verified - Fixed on latest Nightly 67.0a1 (2019-02-03) (64-bit) on Windows 10 x64.

Status: RESOLVED → VERIFIED

Please request uplift to beta when you get a chance.

Flags: needinfo?(dao+bmo)

Comment on attachment 9040372 [details]
Bug 1523578 - In high contrast mode on Windows 10, don't override the lwtheme window background. r=ntim

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

not sure

User impact if declined

see comment 0

Is this code covered by automated tests?

No

Has the fix been verified in Nightly?

Yes

Needs manual test from QE?

No

If yes, steps to reproduce

List of other uplifts needed

None

Risk to taking this patch

Low

Why is the change risky/not risky? (and alternatives if risky)

High contrast mode + lwtheme is pretty much an edge case, and the fix is isolated to only affect that.

String changes made/needed

Flags: needinfo?(dao+bmo)
Attachment #9040372 - Flags: approval-mozilla-beta?

Comment on attachment 9040372 [details]
Bug 1523578 - In high contrast mode on Windows 10, don't override the lwtheme window background. r=ntim

[Triage Comment]
Improves lwthemes when in Win10 high contrast mode. Approved for 66.0b6.

Attachment #9040372 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Whiteboard: [qa-triaged]
Duplicate of this bug: 1525936

Verified - Fixed on latest Beta 66.0b6 (64-bit) on Windows 10 x64.

Flags: qe-verify+
Whiteboard: [qa-triaged]
You need to log in before you can comment on or make changes to this bug.