Closed Bug 1523598 Opened 2 years ago Closed 2 years ago

Disable WebRender before shipping Firefox 66

Categories

(Core :: Graphics: WebRender, defect, P2)

Other Branch
defect

Tracking

()

RESOLVED FIXED
Root Cause Product Decision
Tracking Status
firefox66 blocking fixed
firefox67 --- unaffected

People

(Reporter: kats, Assigned: kats)

References

(Blocks 1 open bug)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1510289 +++

+++ This bug was initially created as a clone of Bug #1499088 +++

In bug 1498711 we turned on WebRender without #ifdef guards so that it can ride to late beta.

However, until we're ready to let it ride to release, we'll need to turn it back off in beta for the last build before RC. Bug 1499088 did that for the 64 beta train, bug 1510289 did it for the 65 train, and this bug is tracking doing the same thing for the 66 train. This bug should block the 66 release so that we don't accidentally ship WebRender on 66 release.

Attachment #9041491 - Flags: review?(jmuizelaar)
Attachment #9041491 - Flags: review?(jmuizelaar) → review+

Comment on attachment 9041491 [details] [diff] [review]
Disable WR on 66 release

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

Bug 1490742

User impact if declined

WebRender will get turned on in release for the MVP audience when 65 release goes out the door

Is this code covered by automated tests?

Yes

Has the fix been verified in Nightly?

No

Needs manual test from QE?

Yes

If yes, steps to reproduce

On a desktop windows 10 machine with NVidia graphics, ensure webrender is turned off by default (check in about:support)

List of other uplifts needed

none

Risk to taking this patch

Low

Why is the change risky/not risky? (and alternatives if risky)

Pref flip. We did the same thing for 65 in bug 1510289

String changes made/needed

None

Attachment #9041491 - Flags: approval-mozilla-release?

If you want to turn it on in 66 release you're welcome to do so. It won't be on by default.

Comment on attachment 9041491 [details] [diff] [review]
Disable WR on 66 release

Disabling WebRender for the release candidate build on Monday.
Attachment #9041491 - Flags: approval-mozilla-release?
Attachment #9041491 - Flags: approval-mozilla-release-
Attachment #9041491 - Flags: approval-mozilla-beta+
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED

Please specify a root cause for this bug. See :tmaity for more information.

Root Cause: --- → ?

This one isn't a defect, as per our email discussion. The feature was disabled per a pre-existing plan.

Root Cause: ? → ---
Flags: needinfo?(tmaity)

As per our email discussion, marking RCA as "product Decision"

Root Cause: --- → Product Decision
Flags: needinfo?(tmaity)
You need to log in before you can comment on or make changes to this bug.