Closed Bug 1523914 Opened 4 years ago Closed 4 years ago

private browsing panel may display on non-private window

Categories

(WebExtensions :: General, defect, P5)

67 Branch
defect

Tracking

(firefox65 disabled, firefox66 disabled, firefox67 affected)

RESOLVED WONTFIX
Tracking Status
firefox65 --- disabled
firefox66 --- disabled
firefox67 --- affected

People

(Reporter: cbadescu, Unassigned)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

Attachments

(1 file)

Attached image Bug.gif

[Affected versions]:

  • Firefox 67.0a1 (20190130094929)

[Affected platforms]:

  • Win 7 64-bit
  • Mac OS X 10.14.1

[Prerequisites]
Set extensions.allowPrivateBrowsingByDefault to false and restart the browser.

[Steps to reproduce]:

  1. Open the Firefox browser.
  2. Open the Private Window for the first time.
  3. Switch back to the Normal Window.
  4. Observe the hamburger menu.

[Actual results]:

  • The doorhanger for the Private Window is displayed in the Normal Window.

[Expected results]:

  • The doorhanger for the Private Window is displayed only for Private Window.

Please see the attached video.

Ultimately we will want to replace the panel with something in about:privatebrowsing (bug 1516670). The app menu panel just works this way, I don't think it's a big deal, certainly not a blocker.

Depends on: 1516670
Priority: -- → P5
Summary: Unintended behavior for the doorhanger displayed at the first visit → private browsing panel may display on non-private window

Also not a regression, this is how the appmenu panel works.

Keywords: regression

We are going to live with this quirk. There is little value in fixing it in light of bug 1516670 and the work that would be needed to change the default behavior of the appmenu panel.

Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.