Closed Bug 1524250 Opened 11 months ago Closed 10 months ago

Font weight renders more bold than previous Firefox versions on macOS

Categories

(Core :: Graphics, defect)

65 Branch
Unspecified
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1531867

People

(Reporter: bohemenian, Unassigned)

References

Details

Attachments

(4 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:65.0) Gecko/20100101 Firefox/65.0

Steps to reproduce:

This issue appeared from Firefox 65 on macOS Mojave. It seems that Firefox may have changed the default for -moz-osx-font-smoothing.

If I open https://github.com/Modernizr/Modernizr/#readme, the font renders more bold than in Firefox 64 (and more bold when compared to both Chrome and Safari).

If I apply the following CSS style however, fonts return to their familiar (slightly thinner) shape.

html {
    -moz-osx-font-smoothing: grayscale;
    font-weight: 400; /* This doesn't actually change anything when compared to the default, but seems to be needed to trigger a rerender */
}

It's worth noting that I have noticed this particularly with sites that use system default fonts. GitHub uses macOS's system default (San Fransisco), Wikipedia is another site where I noticed this, and they use Helvetica.

Actual results:

Fonts rendered more bold than in previous versions of Firefox, presumably due to a change in the default value for -moz-osx-font-smoothing.

Expected results:

The fonts should have rendered consistently with previous versions of Firefox.

i think this might have been an intentional change by bug 1495282

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:65.0) Gecko/20100101 Firefox/65.0
Build ID: 20190124174741

Hi Fredrik,

Thank you for taking the time to add this report.
I was able to reproduce the issue and I noticed the difference between the two Firefox builds. I will attache a screenshot comparing 65 build to 64 build (20181206201918).

I'm going to add this to the same component as the above bug and ping Chris Peterson for a more advised opinion (or confirmation regarding Comment 2).

Status: UNCONFIRMED → NEW
Component: Untriaged → Widget: Cocoa
Ever confirmed: true
Flags: needinfo?(cpeterson)
OS: Unspecified → macOS
Product: Firefox → Core
Attached image 65 vs 64.png

Thanks for reporting and sharing the screenshots. The heavier fonts are an intentional fix for bug 1495282. macOS 10.14 Mojave changed how font subpixel aliasing worked. The problem was fixed for Retina displays by Skia bug 1502152, but that fix caused a similar font regression on non-Retina displays. That regression was fixed by bug 1495282.

You can opt back into the lighter fonts in macOS Settings's "Use font smoothing". I did. :)

Blocks: 1495282
Status: NEW → RESOLVED
Closed: 10 months ago
Flags: needinfo?(cpeterson)
Resolution: --- → WONTFIX

But this is not right solution it is not even any solution.
I have checked "use font smoothing when available" and it really does not help at all!
It looks still same, still much bolder than in 64!

You just broke all web pages and it is ok for you? Good to know.

Flags: needinfo?(mstange)

For comparison, here is a screenshot from macOS 10.14.3 Mojave (on a Retina MacBook Pro) comparing (top down):

  • Firefox 60 (ESR)
  • Firefox 67 Nightly
  • Chrome 73
  • Safari 12

With the Skia fix from bug 1495282, Firefox 65+ does have bolder text than Firefox 60, but Firefox 65+ now matches the font weight of Chrome 73 and Safari 12. Since Apple changed how font antialiasing works in macOS 10.14 Mojave, we can assume that whatever font weight Apple uses in Safari is the "correct" weight as intended by Apple.

Hey cpeterson, please check out bug 1526888 - just like for jan.nov, my experience is that this is not at all about rendering it the same as other browsers. I have font smoothing enabled, and Firefox 65 renders some text as if it were bold, while other browsers (I tested the latest Chrome and Safari) match Firefox 64's rendering.

Duplicate of this bug: 1526888

Hi,
I am developer in Capitolis, we develop fintech platform for capital banks.
We face the same issue in our application when using https://fonts.googleapis.com/css?family=Open+Sans:300,400,600,700 fonts.
Why status of this issue is "RESOLVED WONTFIX" ?

The UX design team investigated this issue and concluded that:

  • Firefox 67 with dark-on-light text is about the same as Chrome
  • Firefox 67 with dark-on-light text actually appears slightly thinner than Safari
  • Chrome with light-on-dark text is bolder than Safari
  • Firefox 67 with light-on-dark text is bolder than Safari
  • Firefox 67 with light-on-dark text is about the same (maybe slightly bolder) as Chrome

Lee has a fix in bug 1531867.

Flags: needinfo?(mstange)
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 1531867
Component: Widget: Cocoa → Graphics
You need to log in before you can comment on or make changes to this bug.