Closed Bug 1524284 Opened 1 year ago Closed 1 year ago

Enable WebRender by default on modern Intel desktop gpus

Categories

(Core :: Graphics: WebRender, enhancement)

Unspecified
Windows 10
enhancement
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox67 --- fixed

People

(Reporter: jrmuizel, Assigned: jrmuizel)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

No description provided.

This enables WebRender on a small subset of modern Intel gpus.

I think you will see a lot of crashes due to Bug 1479795. I used to hit that crash way more easily with WR than without it.
Newer drivers work perfectly, but the one pushed by Windows Update is bugged.

Pushed by jmuizelaar@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7998879d6713
Enable WebRender by default on modern Intel desktop gpus. r=kats
Assignee: nobody → jmuizelaar
OS: Unspecified → Windows 10
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Depends on: 1525084

What are "modern intel desktop GPUs"?

I had a not-that-great experience running WR enabled on Intel Skylake (HD 520) on both - Windows and Linux on a 4K display.
Rendering was pixel-perfect, performance however was not that gread - Firefox felt somehow sluggish on many pages.
So no hard numbers, just a "feel" - maybe pushing 4k pixels at each redraw is a bit tough for those GPUs (this makes me wonder how WR will perform efficiency-wise on battery-powered devices - memory bandwidth is quite costly energy-wise).

(In reply to Clemens Eisserer from comment #5)

What are "modern intel desktop GPUs"?

Right now that means Skylake and newer. Very shortly it will be Haswell and newer.

I had a not-that-great experience running WR enabled on Intel Skylake (HD 520) on both - Windows and Linux on a 4K display.
Rendering was pixel-perfect, performance however was not that gread - Firefox felt somehow sluggish on many pages.
So no hard numbers, just a "feel" - maybe pushing 4k pixels at each redraw is a bit tough for those GPUs (this makes me wonder how WR will perform efficiency-wise on battery-powered devices - memory bandwidth is quite costly energy-wise).

Is your experience recent? i.e have you tried since picture caching was enabled? If so can file bugs for any pages you encounter this today?

Regressions: 1540449

Why is the Intel UHD Graphics 620 (Kabylake GT2) not considered an modern GPU? The UHD Graphics 630 is considered new. I couldn't find any major difference?

The current ids used are the desktop class ones. We should probably expand the list.

Regressions: 1570879

I can confirm that force enable of Webrender on my Lenovo laptop with Intel HD Graphics 620 (Kaby Lake-U GT2) gives me smoother scrolling and better user experience, especially in 4k. Please reconsider Intel HD 620 using Webrender by default.

You need to log in before you can comment on or make changes to this bug.