Closed Bug 1540449 Opened 3 years ago Closed 3 years ago

First downloaded item in the Library window isn't visually selectable/focusable, when opening the Library for the first time in a session

Categories

(Core :: Graphics: WebRender, defect, P2)

defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: itiel_yn8, Unassigned)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

STR that may very well not work for you, but is 90% reproducible for me in my main profile:

  1. Download 2 different files using latest Nightly
  2. Restart Nightly, wait a few seconds for it to fully load (important)
  3. Ctrl+J
  4. The first downloaded item is not focusable/selectable (though double or right clicking works), the second item is. Closing the Library window and re-opening will make the item focusable.

I can't reproduce on a fresh profile. I've tried copying places.sqlite from my main profile over to the new profile and restarted- still not reproducible.
On my main profile I've tried disabling all extensions and restarted- this still occurs afterwards.

Nothing interesting in the browser toolbox when I do it on my main profile, just the following:
Array.forEach is deprecated; use Array.prototype.forEach instead
Array.every is deprecated; use Array.prototype.every instead

See screencast.

Attached image Screencast

Mozregression leads me to bug 1524284 as the regressor but I'm not sure my tests are accurate.

How can I disable WebRender to verify?
gfx.webrender.all is already set to false, but in about:support I see:
opt-in by default: WebRender is an opt-in feature
available by user: Qualified enabled by pref

btw my GPU is indeed Intel HD Graphics 530, as requested here:
https://hg.mozilla.org/mozilla-central/rev/7998879d6713

First known bad build to exhibit the issue: 2019-02-01

(In reply to Itiel from comment #2)

Mozregression leads me to bug 1524284 as the regressor but I'm not sure my tests are accurate.

How can I disable WebRender to verify?
gfx.webrender.all is already set to false, but in about:support I see:
opt-in by default: WebRender is an opt-in feature
available by user: Qualified enabled by pref

gfx.webrender.force-disabled?

Component: Theme → Graphics: WebRender
Product: Firefox → Core
Regressed by: 1524284

(In reply to Dão Gottwald [::dao] from comment #3)

(In reply to Itiel from comment #2)

Mozregression leads me to bug 1524284 as the regressor but I'm not sure my tests are accurate.

How can I disable WebRender to verify?
gfx.webrender.all is already set to false, but in about:support I see:
opt-in by default: WebRender is an opt-in feature
available by user: Qualified enabled by pref

gfx.webrender.force-disabled?

Ah yes, thank you. Not sure how didn't I find this before.

So yes, disabling WebRender fixes this.

Blocks: wr-intel
Priority: -- → P2
Blocks: wr-intel-mvp
No longer blocks: wr-intel

Unable to reproduce this anymore.
Will re-open if this will resurface.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.