Port some tests to QuantumBar (Search Engine results, a11y label ...)

RESOLVED FIXED in Firefox 67

Status

()

enhancement
P1
normal
RESOLVED FIXED
5 months ago
5 months ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

unspecified
Firefox 67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

(Whiteboard: [fxsearch])

Attachments

(1 attachment)

Assignee

Description

5 months ago

Split out from bug 1522489 as I think it may be too much to do in one go, and getting ported tests landed will help prevent regressions as well as fixing other issues.

Assignee

Updated

5 months ago
Blocks: 1524539
Assignee

Comment 1

5 months ago

This starts porting other tests to work with QuantumBar and starts expanding UrlbarTestUtils.jsm with more helper functions.

For the tests, I'm generally using replacing with UrlbarTestUtils except for promiseAutocompleteResultPopup/promiseSearchComplete. These functions feel like they need a more in-depth change (bug 1522902), but probably not until we can remove the old bar.

browser_autocomplete_a11y_label.js and browser_autocomplete_autoselect.js are partially ported, but won't run on QuantumBar yet due to missing functionality.

Comment 4

5 months ago
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ca560af9a557
Port some tests to QuantumBar (Search Engine results, a11y label, autoselect, tab switch reset). r=mak

Comment 5

5 months ago
bugherder
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
You need to log in before you can comment on or make changes to this bug.