Closed Bug 1524719 Opened 4 years ago Closed 3 years ago

Render RSS/Atom files using the XML pretty printer instead of triggering a download prompt

Categories

(Core :: XML, defect, P3)

65 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 155730
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- wontfix
firefox66 --- affected
firefox67 --- affected

People

(Reporter: toupeira, Unassigned)

References

()

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0

Steps to reproduce:

Visit a URL with a MIME type of application/atom+xml or application/rss+xml

(Example: http://www.squarefree.com/feed)

Actual results:

Firefox prompts to open or save the file. If I choose to open the file with Firefox, it opens in a new tab but with the file:// URL of the temporary download.

Expected results:

Render the file pretty-printed like any other XML file, or as plain-text if that's not possible.

I realize you've removed feed rendering in Firefox 65, but this new behaviour is quite irritating since any other plain-text MIME type renders just fine. As a developer I just want a quick way to debug the output of feeds. Also see https://bugzilla.mozilla.org/show_bug.cgi?id=155730 ;-)

In case you were thinking of users with desktop feed readers, maybe make this configurable in Preferences → Applications with a "Preview in Firefox" option like for PDFs.

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0
20190201221223

It looks like this was introduced with the removal of the feed preview. I tried the first release with bug 1477669 and it's reproducible there.

Blocks: 1477669
Status: UNCONFIRMED → NEW
Has STR: --- → yes
Component: Untriaged → File Handling
Ever confirmed: true
Flags: needinfo?(gijskruitbosch+bugs)
OS: Unspecified → All
Hardware: Unspecified → All

Changing what mimetypes we use for the XML pretty printer is a question for Core XML. I don't have a strong opinion on this, though making it configurable is probably a little more tricky.

(In reply to Markus Koller from comment #0)

since any other plain-text MIME type renders just fine.

This isn't strictly true. E.g. putting this in the URL bar: data:text/x-log,Hello shows a download prompt for me.

As a developer I just want a quick way to debug the output of feeds. Also see https://bugzilla.mozilla.org/show_bug.cgi?id=155730 ;-)

Sure, but also:

https://bugzilla.mozilla.org/show_bug.cgi?id=155730#c65

(In reply to David Baron :dbaron: from bug 155730 comment #65)

(In reply to comment #60)

The reason I reported the bug initially was for a real-life problem: Firefox
wouldn’t display application/rdf+xml back then, and would only offer to
download it.

I think having UI in the XML prettyprinter (and in view source) to allow
them to show documents that they don't handle by default would be a better
solution for this. (Could this be done by an extension?)
The XML prettyprinting UI is not a useful default for most of our users.

(Emphasis mine)

Coming back to your comment:

In case you were thinking of users with desktop feed readers, maybe make this configurable in Preferences → Applications with a "Preview in Firefox" option like for PDFs.

The current state is simply the default behavior for arbitrary XML types.

Component: File Handling → XML
Flags: needinfo?(gijskruitbosch+bugs)
Product: Firefox → Core
Summary: Render RSS/Atom files inline as XML instead of triggering a download prompt → Render RSS/Atom files using the XML pretty printer instead of triggering a download prompt
Duplicate of this bug: 1524978

(In reply to :Gijs (he/him) from comment #2)

Ok fair enough, thanks for looking into this!

Using the XML pretty printer for arbitrary XML types would be my preferred solution, but in the meantime I found two workarounds that work well enough for me:

AFAIK, we don't plan to change this for core XML, but adding Peter here to confirm.

Flags: needinfo?(peterv)
Priority: -- → P3
See Also: → 1477669
See Also: 1477669

I can not use a side aggregator like Feed Demon due of this modification! Now Firefox send not http but file in temp folder to it. Please, repair.

I'm going to mark this as a dupe of bug 155730, any solution should apply to all application/*+xml types.

Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(peterv)
Resolution: --- → DUPLICATE
Duplicate of bug: */*+xml
You need to log in before you can comment on or make changes to this bug.