Status

enhancement
P1
normal
RESOLVED FIXED
Last year
5 months ago

People

(Reporter: Gijs, Assigned: Gijs)

Tracking

(Depends on 1 bug, Blocks 1 bug)

Trunk
Firefox 64
Dependency tree / graph

Firefox Tracking Flags

(firefox63 wontfix, firefox64 fixed)

Details

(Whiteboard: [overhead:noted])

Attachments

(1 attachment)

As part of removing feed and live bookmark support, we should remove about:feeds and the "Subscribe..." UI that opens it.
Depends on: 1477670
Blocks: 1477671
Priority: -- → P1
Whiteboard: [overhead:noted]
Depends on: 1488954
Depends on: 1491243
No longer depends on: 1488954
Duplicate of this bug: 1457787
Can't this be changed into something like json viewer instead? I usually use feed preview to validate my rss/atom feeds.
But you can't view what's inside with that. Validate here I mean includes viewing how the content looks like.
I don't know about others but firefox preview is essential to me for writing rss/atom feeds. I don't know even know other apps for previewing apart of internet explorer. Additionally, having it built into firefox means I get benefit of history and cookies.

Also unlike json, feeds are sometimes html which means it can't be viewed properly through console and anything that can view this means it's got html renderer in it... which browser conveniently already has.

I sometimes use it to preview feeds before actually subscribing to but the development side usage is more important to me.

If you've got other recommendation, I'm all ears though this means one extra hurdle for developers looking to write rss/atom feeds.
How the content looks like is highly dependent on the feed reader, so I'm not sure there's a globally good tool for that. Any feed reader may be good as far as I can tell, so I'd just look around for some stats about the most widely used ones, and check your feeds with those. In the end it's the same as "is my website displayed correctly?" and unfortunately there's not yet much way out than testing it with the most common browsers.
Pretty sure most web based feed readers can't read my internal development feeds though :)

Some don't even have preview feature (like tt-rss) or maybe even permanently cache feeds so I can't just update the code and refresh with those.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Blocks: 1499092
Blocks: 1499350
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/c8afe4845022
remove feed preview code and associated files/code, r=flod,mak,nika
https://hg.mozilla.org/mozilla-central/rev/c8afe4845022
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Product: Firefox → Firefox Graveyard
Depends on: 1524719
See Also: → 1524719
See Also: 1524719
You need to log in before you can comment on or make changes to this bug.