Closed Bug 1524917 Opened 10 months ago Closed 9 months ago

Pages don't fit the screen after zooming in with one-touch pinch

Categories

(Core :: Panning and Zooming, defect, P3)

67 Branch
All
Android
defect

Tracking

()

RESOLVED DUPLICATE of bug 1512838

People

(Reporter: csheany, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Android 7.1.1; Tablet; rv:67.0) Gecko/67.0 Firefox/67.0

Steps to reproduce:

  1. Open https://bugzilla.mozilla.org/
  2. Perform a search
  3. Zoom in (double tap drag - one touch pinch)
  4. Zoom in (two finger pinch)

Actual results:

The page is outside the screen

Expected results:

To be determined

Component: General → Panning and Zooming
OS: Unspecified → Android
Product: Firefox for Android → Core
Hardware: Unspecified → All
Version: Firefox 67 → 67 Branch

One-touch pinch is known to be broken on Bugzilla (likely on an entire category of websites that includes Bugzilla). The issue is being tracked in bug 1512838.

Status: UNCONFIRMED → RESOLVED
Closed: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1512838

Would you mind taking a look at the screenshot to confirm it is the same issue?

Flags: needinfo?(botond)

Based on the text being blurry, I would say yes. The blank space on the right looks more like bug 1521330.

Flags: needinfo?(botond)

While I do experience Bug 1512838, this takes it one step further.

It might be the screenshot but the text is actually clear.

While similar, unlike Bug 1521330 the blank space can't be scrolled.

Also, the reflow can be triggered while zoomed in.

It doesn't matter where on the page you zoom, it still jumps.

Would you mind reopening to investigate?

Additional STR,

  1. Open https://bugzilla.mozilla.org/
  2. Perform a search
  3. Zoom in (two finger pinch)
  4. Zoom in (double tap drag - one touch pinch)
  5. Zoom out (two finger pinch)

I can reopen so that in case there is indeed an additional issue we don't lose track of it, but there's no point in investigating until bug 1512838 is fixed first.

Status: RESOLVED → REOPENED
Depends on: 1512838, 1521330
Ever confirmed: true
Priority: -- → P3
Resolution: DUPLICATE → ---
Summary: Pages don't fit the screen after zooming in → Pages don't fit the screen after zooming in with one-touch pinch

Thank you.

Is not being able to zoom out (two finger pinch) after zooming in (double tap drag - one touch pinch) related?

(In reply to csheany from comment #8)

Is not being able to zoom out (two finger pinch) after zooming in (double tap drag - one touch pinch) related?

Yes, that seems consistent with Kats' hypothesis in bug 1512838 comment 4.

Can you retest on the March 18 Nightly, which should have the fix for bug 1512838?

Flags: needinfo?(csheany)

It seems to be working.

Flags: needinfo?(csheany)

Thanks. Duping to bug 1512838.

Status: REOPENED → RESOLVED
Closed: 10 months ago9 months ago
No longer depends on: 1521330, 1512838
Resolution: --- → DUPLICATE
Duplicate of bug: 1512838
You need to log in before you can comment on or make changes to this bug.